X400: Incorrect Time on Message Sent through Gateway to X.400 (194546)



The information in this article applies to:

  • Microsoft Mail Gateway to X.400 3.2

This article was previously published under Q194546

SYMPTOMS

If you send a message through the Microsoft Mail Gateway to X.400, and either of the following conditions are met, the time on the message may be incorrect when you view the message in an e-mail client:

  • The message is sent from Microsoft Exchange Server to Microsoft Mail for PC Networks, or vice versa, and the Microsoft Mail Gateway to X.400 computer is configured for a time zone other than Greenwich mean time. The problem occurs regardless of the time zone for which the Exchange Server computer is set. -or-

  • The message is sent from Microsoft Mail (PC) to Microsoft Mail (PC) through two Microsoft Mail Gateway to X.400 computers, and the computers are not configured for the same time zone.

CAUSE

Microsoft Mail Gateway to X.400 does not properly modify the time on messages to adjust for differences in time zones. This causes the time on the message to be displayed incorrectly when either of the conditions described above are met.

RESOLUTION

A supported fix that corrects this problem is now available from Microsoft, but has not been fully regression-tested and should be applied only to systems experiencing this specific problem.

To resolve this problem, contact Microsoft Product Support Services to obtain the fix. For a complete list of Microsoft Product Support Services phone numbers and information on support costs, please go to the following address on the World Wide Web: The English version of this fix should have the following file attributes or later:
   File Name      Version
   ----------------------
   X400gate.exe   3.2.23
				
This hotfix has been posted to the following Internet location as X400gy2k.exe:

STATUS

Microsoft has confirmed this to be a problem in Microsoft Mail Gateway to X.400 version 3.2.

MORE INFORMATION

When you send a message to or from an Exchange Server or Microsoft Mail (PC) computer, the computer may adjust the time on the message for differences in time zones. This adjustment is intended to ensure that the time on the message is accurate when the message is viewed in an e-mail client, regardless of the time zones in which the Exchange Server or Microsoft Mail (PC) computers are located.

When a message is sent from an Exchange Server computer that is configured for a time zone other than Greenwich mean time, the server adds or subtracts the appropriate number of hours so that the time on the message appears in Greenwich mean time. Similarly, when a message is sent to an Exchange Server computer that is configured for a time zone other than Greenwich mean time, the server adds or subtracts the appropriate number of hours so that the time on the message appears in the time zone in which the server is located. Adjusting the time to Greenwich mean time on outbound messages allows the server that receives the message to easily adjust the time to the appropriate time zone. This ensures that the time on the message is accurate when the message is viewed in an e-mail client.

Microsoft Mail (PC) computers adjust the time on outbound and inbound messages in a similar manner. However, if the message is sent through the Microsoft Mail Gateway to X.400, the time on the message may be not be adjusted properly. If the Microsoft Mail Gateway to X.400 computer is configured for Greenwich mean time, the computer does not attempt to adjust the time on the message. Therefore, the problem described in this article does not occur.

In addition, if the message is sent from Microsoft Mail (PC) to Microsoft Mail (PC) through two Microsoft Mail Gateway to X.400 computers that are configured for a time zone other than Greenwich mean time, and both computers are configured for the same time zone, the incorrect adjustments made by the two computers offset each other, and the problem does not occur.

In all other scenarios, the problem described in this article occurs because the Microsoft Mail Gateway to X.400 does not properly adjust the time on the message.

As indicated above, this problem occurs when a message is sent from Microsoft Mail (PC) to Microsoft Mail (PC) through two Microsoft Mail Gateway to X.400 computers that are not configured for the same time zone. Specifically, this problem occurs when either of the following conditions are met:

  • Both of the Microsoft Mail Gateway to X.400 computers are configured for a time zone other than Greenwich mean time, but the computers are not configured for the same time zone. -or-

  • One of the Microsoft Mail Gateway to X.400 computers is configured for Greenwich mean time, but the other is not.

Modification Type:MajorLast Reviewed:10/16/2002
Keywords:kbbug kbQFE KB194546