FP98: FrontPage Appears to Hang When You Use Dial-Up-Adapter (194237)



The information in this article applies to:

  • Microsoft FrontPage 98 for Windows

This article was previously published under Q194237

For a Microsoft FrontPage 97 and earlier version of this article, see 153685.

SYMPTOMS

When you use a Dial-Up-Adapter to connect to the Internet and you are not currently connected, your computer may appear to hang (stop responding) when you use FrontPage Explorer or FrontPage TCP/IP Test.

CAUSE

If you are using DNS for name resolution, any call to the TCP/IP stack will attempt to resolve to an IP address. If you are not connected to your Internet service provider, there is no DNS server available. The computer will attempt to wait until a DNS server replies.

STATUS

Microsoft has confirmed this to be a problem in the Microsoft products listed at the beginning of this article.

WORKAROUND

To work around this problem, follow these steps:
  1. Find the Hosts file (located in the C:\Windows\ folder). If it does not exist, rename Hosts.sam to Hosts.
  2. Open the Hosts file in a text editor (such as Notepad), and add the following line to the end of the file
          127.0.0.1       <fqdn>
    						
    where <fqdn> is the Fully Qualified Domain Name as specified on the DNS Configuration tab of the TCP/IP Properties tab (double-click the Network icon in Windows Control Panel). For example, if the Host is named Mycomputer and the Domain is called Mynetwork.com, you would add the following line to the Hosts file:
          127.0.0.1       mycomputer.mynetwork.com
    						

Modification Type:MajorLast Reviewed:10/3/2001
Keywords:kbbug KB194237