FIX: No Help File With Distributed App (194196)
The information in this article applies to:
- Microsoft Visual FoxPro for Windows 6.0
This article was previously published under Q194196 SYMPTOMS
No help appears when you press the F1 key or when you select Microsoft Visual
FoxPro Help Topics from the Help menu. This occurs with distributed
applications installed on a system that does not have Visual FoxPro
installed.
CAUSE
The Setup Wizard does not copy either the Foxhhelp.exe or the
Foxhhelpps.dll file when you select the HTML HELP ENGINE in step 2 of the
Setup Wizard.
RESOLUTION
Copy the Foxhhelp.exe file and the Foxhhelpps.dll file from the Visual
FoxPro directory to the distribution directory from which you run the Setup
Wizard. During setup, select ActiveX in step 6 for the Foxhhelpps.dll file.
Also, in step 6, set the target directory to Winsysdir for the Foxhhelp.exe
file and the Foxhhelpps.dll file.
When you install a distributed application on a system that does not have
Visual FoxPro, you must manually register the Foxhhelp.exe file. You can do
this by running the Foxhhelp.exe file with the /REGSERVER option, for
example:
Modification Type: | Minor | Last Reviewed: | 3/7/2005 |
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Keywords: | kbAppSetup kbbug kbfix kbVS600sp3fix kbwizard KB194196 |
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