MHS: Attachment Not Delivered, But No Error Message is Displayed (194145)
The information in this article applies to:
- Microsoft Mail Gateway to MHS 3.0
This article was previously published under Q194145 SYMPTOMS
If you send a message that contains an attachment from MHS to Microsoft
Mail for PC Networks through the Microsoft Mail Gateway to MHS, the
attachment may not be delivered. The message is delivered successfully and
no error messages are displayed, but the attachment remains in the
MHS\MAIL\GATES\<gateway>\OPARCEL folder on the MHS computer, where
<gateway> is the gateway name.
CAUSE
This problem can occur if the Attachment field in the message header is
located after a field with a longer field name. For example, the problem
occurs if the Attachment field is located after the Attachment-name field.
The buffer used to hold the field name may not be cleared after the
contents of the field are processed. Therefore, if the next field name is
shorter, the field name in the buffer may be incorrect. This prevents the
Microsoft Mail Gateway to MHS from delivering the attachment.
RESOLUTION
A supported fix that corrects this problem is now available from Microsoft,
but has not been fully regression tested and should be applied only to
systems experiencing this specific problem.
To resolve this problem, contact Microsoft Product Support Services to
obtain the fix. For a complete list of Microsoft Product Support Services
phone numbers and information on support costs, please go to the following
address on the World Wide Web:
The English version of this fix should have the following file attributes
or later:
File Name Version
---------------------
Outpost.exe 3.0.10
This hotfix has been posted to the following Internet location as
Mhsgy2k.exe:
STATUS
Microsoft has confirmed this to be a problem in Microsoft Mail Gateway to
MHS version 3.0.
Modification Type: | Major | Last Reviewed: | 10/16/2002 |
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Keywords: | kbbug kbQFE KB194145 |
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