FP98: No Server on Port 80 After Laptop Computer Has Been Idle (193958)



The information in this article applies to:

  • Microsoft FrontPage 98 for Windows

This article was previously published under Q193958

For a Microsoft FrontPage 97 and earlier version of this article, see 151349.

SYMPTOMS

When you use FrontPage on certain types of computers, you may receive the following error message:
There is no server on Port 80 at '<Server Name>'

CAUSE

This problem typically occurs with laptop computers, because the Windows 95 power conservation option is enabled. Once the Power Manager is activated, it sends a "shut down" signal to all hardware devices. When the Network Device Interface Specification (NDIS) device receives the signal, it "shuts down" the network card, essentially indicating that the card has been removed. TCP/IP is notified, and the TCP/IP stack is removed. Once the power conservation mode is done, the Personal Web Server, which was running normally, generates a bind to port error message.

STATUS

Microsoft has confirmed this to be a problem in the Microsoft products listed at the beginning of this article.

WORKAROUND

To work around this problem, use any of the following method when you use FrontPage on a laptop computer:
  • Run the computer from AC power rather than from batteries.

    -or-
  • Do not allow the laptop to remain idle for a long period of time.

    -or-
  • To disable the Windows 95 power conservation option, follow these steps:

    • On your Window's Desktop, right-click My Computer and click Properties.
    • Click the Device Manager tab.
    • Click the plus sign next to System Devices.
    • Double-click Advanced Power Management Support.

      If you do not see an Advanced Power Management item, your computer does not support this feature.
    • Click the Settings tab.
    • Click to clear (remove the check mark from) the Enable Power Management Support check box.

Modification Type:MajorLast Reviewed:10/3/2001
Keywords:kbbug KB193958