CSNW Error 85, Local Device Already in Use, When Desktop Icons Are Located on NetWare Server (193806)
The information in this article applies to:
- Microsoft Windows NT Server 4.0 Terminal Server Edition
- Microsoft Windows NT Workstation 4.0
- Microsoft Windows NT Server 4.0
This article was previously published under Q193806 SYMPTOMS
In the following configuration, after you log on and log off several
consecutive times, the network client receives an access denied error
message to one or more network drives located on the NetWare server. Also,
the NET USE command fails with the following error message:
Error 85, Local device already in use
This error message is followed by an access denied error message.
The problem can be cleared on the Windows NT Workstation client by
restarting Client Services for NetWare (CSNW).
Configuration- Windows NT primary domain controller (PDC) running Windows NT Server 4.0
with Gateway Services for NetWare (GSNW)
- Novell NetWare 3.12 server
- Client running Windows NT Workstation 4.0 with Client Services for
NetWare CSNW and:
- Logon script located on the PDC
- Desktop icons stored on the NetWare server (M: drive below)
The Windows NT logon script maps several network drives on the NetWare
server. For example:
net use M: /delete > NUL followed by,
net use M: \\NWserver\share > NUL
NOTE: The same behavior is obtained using a NET USE command with the
/persistent:no switch.
CAUSE
The problem affects one or more drives and the drive where the desktop
icons are located is always affected. The problem is intermittent and is
easier to reproduce when using higher speed processors (200 MHz and more).
RESOLUTION
The solution consists of removing a race condition that potentially exists,
especially when using high speed processors, between process cleanup and
WINLOGON deleting network connections. To resolve this problem, obtain the latest service pack for Windows NT 4.0 or Windows NT Server 4.0, Terminal Server Edition. For additional information, click the following article number to view the article in the
Microsoft Knowledge Base:
152734 How to Obtain the Latest Windows NT 4.0 Service Pack
STATUSMicrosoft has confirmed that this is a problem in Windows NT 4.0 and Windows NT Server 4.0, Terminal Server Edition. This problem was first corrected in Windows NT 4.0 Service Pack 4.0 and Windows NT Server 4.0, Terminal Server Edition Service Pack 4.
Modification Type: | Minor | Last Reviewed: | 9/23/2005 |
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Keywords: | kbHotfixServer kbQFE kbbug kbfix KB193806 |
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