PCM "Execute" Button Unavailable or Dimmed (193784)
The information in this article applies to:
- Microsoft Systems Management Server 1.2 SP4
This article was previously published under Q193784 SYMPTOMS
If a "Run Command on Workstation" job is run through Package Command
Manager (PCM) and the package for the job was created from a .pdf file that
contains "SynchronousSystemExitRequired", PCM may stop in a state where the
Execute button is unavailable or dimmed. The PCM log will show that the job
is continuing indefinitely. Subsequent jobs sent to the computer will also
have the Execute button unavailable, and also will not run.
Viewing the Pcmwin.log file in smstrace reveals that the log is
continuously filling up with messages similar to the following:
[09/28/98 18:21:05] Package Command Manager ==> The running process
handle is 0
[09/28/98 18:21:05] Package Command Manager ==> A job is not in process.
[09/28/98 18:21:07] Package Command Manager ==> Monitoring running job.
[09/28/98 18:21:07] Package Command Manager ==> The running process
handle is 0
[09/28/98 18:21:07] Package Command Manager ==> A job is not in process.
[09/28/98 18:21:09] Package Command Manager ==> Monitoring running job.
[09/28/98 18:21:09] Package Command Manager ==> The running process
handle is 0
[09/28/98 18:21:09] Package Command Manager ==> A job is not in process.
If the job is run by using the Package Command Manager service, the job may appear to finish successfully but subsequent jobs may not run and the Pacman.log file may show entries similar to:
Job still running............~ $$<SMS_PACKAGE_COMMAND_MANAGER_NT><Tue Nov 10 17:56:25 1998~><thread=112>
Job still running............~ $$<SMS_PACKAGE_COMMAND_MANAGER_NT><Tue Nov 10 17:56:27 1998~><thread=112>
Job still running............~ $$<SMS_PACKAGE_COMMAND_MANAGER_NT><Tue Nov 10 17:56:29 1998~><thread=112>
Job still running............~ $$<SMS_PACKAGE_COMMAND_MANAGER_NT><Tue Nov 10 17:56:31 1998~><thread=112>
Job still running............~ $$<SMS_PACKAGE_COMMAND_MANAGER_NT><Tue Nov 10 17:56:33 1998~><thread=112>
CAUSE
This problem only occurs if the .pdf file used to create the package
contains "SynchronousSystemExitRequired".
RESOLUTION
A supported fix that corrects this problem is now available from Microsoft,
but has not been fully regression tested and should be applied only to
systems experiencing this specific problem. If you are not severely
affected by this specific problem, Microsoft recommends that you wait for
the next Systems Management Server service pack that contains this fix.
To resolve this problem immediately, contact Microsoft Product Support
Services to obtain the fix. For a complete list of Microsoft Product
Support Services phone numbers and information on support costs, please go
to the following address on the World Wide Web:
The English version of this fix should have the following file attributes
or later:
Date Time Size File name Platform
----------------------------------------------------
9/21/98 6:50pm 442 KB Pcmwin16.exe (x86)
9/21/98 6:50pm 455 KB Pcmwin32.exe (x86)
9/24/98 10:54am 260 KB Pcmsvc32.exe (x86)
9/21/98 6:50pm 1,142 KB Pcmwin32.exe (Alpha)
9/24/98 10:53am 776 KB Pcmsvc32.exe (Alpha)
WORKAROUND
To work around this problem, try any of the following:
- Remove the SynchronousSystemExitRequired from the PDF.
-or-
- Use the PCM from Systems Management Server Service Pack 3.
-or-
- Make the job mandatory.
STATUS
Microsoft has confirmed this to be a problem in Systems Management Server
version 1.2 Service Pack 4.
Modification Type: | Minor | Last Reviewed: | 9/23/2005 |
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Keywords: | kbHotfixServer kbQFE kbfix kbPCM kbprb KB193784 |
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