PRB: Unable to Load Client Extension Because of a Missing DLL (193711)



The information in this article applies to:

  • Microsoft Exchange Development Kit (EDK) 5.0
  • Microsoft Exchange Development Kit (EDK) 5.5
  • Microsoft Outlook 98
  • Microsoft Outlook 97

This article was previously published under Q193711

SYMPTOMS

When you launch Outlook you may get an error message if an extension to the client is unable to load. The error message looks similar to the following:
The add-in "c:\winnt\system32\myfile.dll" could not be installed or loaded. Unable to load "c:\winnt\system32\myfile.dll". You may be out of memory, out of system resources, or missing a .dll file.

CAUSE

The extension may be dependant on a .dll file that is either missing, not in the expected location, or not in the system path.

RESOLUTION

Here are four methods you can use to determine which DLLs are required:
  • You can use the DumpBin.exe that is a part of Visual C++. Use the following command:
           DUMPBIN /imports myfile.dll /out:myout.txt
    						
    This generates a file that lists the DLLs that Myfile.dll is dependent upon.

    -or-
  • Right-click the .dll file in Windows Explorer and select Quick View. Under "Import Table" you see a list of the DLLs that Myfile.dll is dependent upon.

    -or-
  • Use the utility Dependency Walker, Depends.exe, that is part of Visual C++ 6.0. Double-click Depends.exe. Once started, open the .dll file. In the left panel there is a heirarchical tree of the DLLs and the subsequent DLLs that they depend on.

Modification Type:MajorLast Reviewed:3/12/2004
Keywords:kbprb KB193711