PRB: Error "Rights.Dat is already open" When Running Ddupd.exe (193586)



The information in this article applies to:

  • Microsoft Visual SourceSafe for Windows 6.0

This article was previously published under Q193586

SYMPTOMS

The following error occurs when running the Ddupd.exe utility to upgrade the database to the 6.0 format:
Rights.Dat is already open.

CAUSE

This happens because the SourceSafe Admin or one or more users are logged in and are using the database.

RESOLUTION

Before running the Ddupd.exe make sure that all the users are logged out of SourceSafe and that the SourceSafe Admin is closed.

STATUS

This behavior is by design.

MORE INFORMATION

Steps to Reproduce Behavior

  1. Log into SourceSafe as a valid user, or open the SourceSafe Admin.
  2. From the Win32 directory of the SourceSafe install and execute the following command:
          DDUPD <path to the data directory> [-undo] [-redo]
    						
    The following message displays:
    File <path to data directory>\rights.dat is already open.

REFERENCES

Visual SourceSafe 6.0 Help; search on: "DDUPD"

Modification Type:MajorLast Reviewed:5/1/2001
Keywords:kbddconv kbprb KB193586