"Unable to read file" Error Opening the Add-Ins Dialog Box (193539)



The information in this article applies to:

  • Microsoft Excel 97 for Windows
  • Microsoft Excel for Windows 95

This article was previously published under Q193539

SYMPTOMS

When you try to open the Add-Ins dialog box, you may receive the following error message:
Unable to read file.
The error message only appears the first time that you try open the Add-Ins dialog box after you start Microsoft Excel. It will not occur again until you close and reopen Excel.

CAUSE

This problem may occur when the following conditions are true:

  • On the Tools menu, you click Add-Ins.

    -and-
  • The MSCreate.dir file in the Program Files\Microsoft Office\Office\Library folder is not hidden.

RESOLUTION

To resolve this problem, follow these steps:

  1. In Windows Explorer, open the Program Files\Microsoft Office\Office\Library folder.
  2. On the View menu, click Options, click the View tab, click Show All Files, and then click OK.
  3. Click the MSCreate.dir file. On the File menu, click Properties.
  4. In the Properties dialog box, ensure the Archive, Hidden, and Read-only attributes are selected (checked). Click OK

STATUS

This behavior is by design of the programs listed at the beginning of this article.

MORE INFORMATION

The Setup program creates Mscreate.dir (a 0-byte hidden file) in each folder that Setup creates to indicate that the folder was created by Setup.

When you run Setup in maintenance mode and remove a component or click Remove All, Setup uses this file to determine whether an empty folder can be removed. If an empty folder does not contain this file, when you run Setup in maintenance mode, Setup will not remove this folder.


Modification Type:MinorLast Reviewed:8/18/2005
Keywords:kberrmsg kbprb KB193539