Computer with IDE DMA Hard Disk Hangs When Resumed (193473)
The information in this article applies to:
This article was previously published under Q193473 SYMPTOMS
When a Windows 98-based computer is placed into Standby mode and then
resumed, the computer may stop responding (hang) if it contains an
Integrated Drive Electronics (IDE) hard disk that is accessed using
Direct Memory Access ([DMA], which is also known as Bus Mastering).
CAUSE
When it resumes, Windows 98 issues an incorrect wakeup command sequence
to an IDE hard disk that uses DMA.
This problem has been reported to occur with the following portable
computers running Windows 98:
- IBM ThinkPad 770E
- IBM ThinkPad 770ED
- IBM ThinkPad 600
- IBM ThinkPad 560D
- IBM ThinkPad 380Z
RESOLUTION
A supported fix that corrects this problem is now available from
Microsoft, but has not been fully regression tested and should be applied
only to computers experiencing this specific problem. To resolve this
problem immediately, contact Microsoft Technical Support to obtain the
fix. If you are not severely impacted by this specific problem, Microsoft
recommends that you wait for the next service pack that contains this fix.
For a complete list of Microsoft Technical Support phone numbers and
information on support costs, please go to the following address on the
World Wide Web:
This fix should have the following file attributes (or later):
File name Version Date Time Size
---------------------------------------------------------
Esdi_506.pdr 4.10.2001 9/28/98 8:01pm 24,430 bytes
Ios.vxd 4.10.2001 9/28/98 8:01pm 69,478 bytes
STATUS
Microsoft has confirmed this to be a problem in Microsoft Windows 98.
This problem was corrected in Windows 98 Second Edition.
Modification Type: | Minor | Last Reviewed: | 9/22/2005 |
---|
Keywords: | kbHotfixServer kbQFE kbHardware kbprb KB193473 |
---|
|