PI: Invalid Page Fault when Opening Fpx File from Kodak Camera (193305)



The information in this article applies to:

  • Microsoft Picture It! 2.0
  • Microsoft Picture It! 99
  • Microsoft Picture It! Express 2000
  • Microsoft Picture It! Express 2001
  • Microsoft Picture It! Express 2002 1.0
  • Microsoft Picture It! Photo 2001
  • Microsoft Picture It! Photo 2002 1.0
  • Microsoft Picture It! Photo Premium 2001
  • Microsoft Picture It! Photo Premium 2002, version 1.0
  • Microsoft Picture It! Publishing 2001 Gold
  • Microsoft Picture It! Publishing 2002, Gold, version 1.0
  • Microsoft Picture It! Publishing 2001 Platinum
  • Microsoft Picture It! Publishing Platinum 2002 1.0
  • Microsoft Picture It! Publishing 2001 Silver
  • Microsoft Greetings 2002 1.0

This article was previously published under Q193305

SYMPTOMS

When you open a FlashPix (.fpx) file in Microsoft Picture It! you may receive one of the following errors.
PICTURE caused an invalid page fault in PISERVER.DLL

-or-

PICTURE caused an invalid page fault in module KERNEL32.DLL
This error is sometimes followed by another error.
PICTURE caused an invalid page fault in MFC42.DLL

CAUSE

These errors can occur when opening .fpx files created by a Kodak DC260 camera if the files were transferred from the camera's flash memory card using a flash-to-PCMCIA adapter card.

The Kodak DC220 is very similar to the DC260 and may exhibit the same problem.

RESOLUTION

Take the .fpx images off the camera using Microsoft Picture It! or the Kodak Picture Easy software that came with the camera.

To acquire the images using Microsoft Picture It! do the following.

  1. Install the Kodak DC220/DC260 camera software on your computer.
  2. Run Picture It!, click Get Picture, and then Digital Camera.
  3. Select the Kodak DC220/DC260 camera from the list.
  4. Follow the steps in the task pane. The Kodak Digital Access TWAIN Acquire Software appears.
  5. Click Camera Contents to see the images stored on the camera.
  6. Select the images you want to download and click Transfer.
To work around this issue, you can save the camera images as .jpg files. To do this, visit the following Kodak Web site:

STATUS

Microsoft has confirmed this to be a problem in the Microsoft products listed at the beginning of this article.

MORE INFORMATION

Upgrading to Kodak DC220/DC260 firmware 1.0.4 does not fix this problem.

Modification Type:MinorLast Reviewed:12/28/2004
Keywords:kberrmsg kbprb KB193305