Choppy Audio When Participating in a NetMeeting Conference (193236)



The information in this article applies to:

  • Microsoft NetMeeting 2.1 for Windows 98
  • Microsoft NetMeeting 2.1 for Windows NT 4.0
  • Microsoft NetMeeting 2.1 for Windows 95

This article was previously published under Q193236
IMPORTANT: This article contains information about editing the registry. Before you edit the registry, make sure you understand how to restore it if a problem occurs. For information about how to do this, view the "Restoring the Registry" Help topic in Regedit.exe or the "Restoring a Registry Key" Help topic in Regedt32.exe.

SYMPTOMS

Audio you receive while participating in a NetMeeting conference over the Internet or a local area network (LAN) may sound choppy.

CAUSE

This behavior can occur if any of the following conditions exists:

  • You are using the Microsoft Windows NT 4.0 Sound Blaster drivers currently available on Creative Lab's Web site.
  • Microsoft DirectSound 5.0 or later, which is included with Microsoft DirectX 5.0 or later, is not installed on your computer.
  • DirectX 5.0 is installed, but your sound card drivers do not support DirectSound 5.0 or later.

    -or-

    You disable DirectSound support in NetMeeting.

    -or-

    DirectX 5.0 is not installed.

    -and-

    The value data for the MinAudioDelayMS string value is set too low.

RESOLUTION

WARNING: Using Registry Editor incorrectly can cause serious problems that may require you to reinstall your operating system. Microsoft cannot guarantee that problems resulting from the incorrect use of Registry Editor can be solved. Use Registry Editor at your own risk.

For information about how to edit the registry, view the "Changing Keys And Values" Help topic in Registry Editor (Regedit.exe) or the "Add and Delete Information in the Registry" and "Edit Registry Data" Help topics in Regedt32.exe. Note that you should back up the registry before you edit it.

To resolve this behavior, follow the steps in the appropriate section below:

Using Current Windows NT 4.0 Sound Blaster Device Drivers

If you are using the Windows NT 4.0 Sound Blaster drivers currently available on Creative Lab's Web site, use either of the following methods to work around this behavior:

  • Add the MinAudioDelayMs string value to the registry or modify its value data if it already exists. For information about how to do so, see the "Existing Drivers Do Not Support DirectSound 5.0 or Later" section later in this article.
  • Use the Sound Blaster drivers included with Windows NT 4.0. Note that these are half-duplex drivers as opposed to the full-duplex drivers available from Creative Labs.

DirectSound 5.0 or Later Is Not Installed

If DirectSound 5.0 or later is not installed on your computer, download the latest version of DirectX from the following Microsoft Web site: NOTE: DirectX 5.0 is included with Windows 98. DirectX 5.0 is not available for Windows NT 4.0.

DirectX 5.0 Is Installed But Existing Drivers Do Not Support DirectSound 5.0 or Later, or DirectSound Is Disabled in NetMeeting, or DirectX 5.0 Is

Not Installed, and the MinAudioDelayMS Value Data Is Too Low

If your sound card drivers do not support DirectSound 5.0 or later, use Registry Editor to add the "MinAudioDelayMs" (without quotation marks) string value with a value data of "240" (without quotation marks) to the following registry key:
   HKEY_LOCAL_MACHINE\Software\Microsoft\Internet Audio\NacObject
				
NOTE: If DirectX 5.0 or later is installed on your computer, NetMeeting ignores the MinAudioDelayMs string value. Microsoft does not recommended setting the MinAudioDelayMs value data to any other value, as doing so may result in poor audio, no audio, or other unexpected results.

Modification Type:MajorLast Reviewed:11/14/2003
Keywords:kbenv kbprb KB193236