XADM: Per-Entity MTA Counters Not Working After Upgrade (193221)



The information in this article applies to:

  • Microsoft Exchange Server 5.0
  • Microsoft Exchange Server 5.5
  • Microsoft Exchange Server 5.5 SP1

This article was previously published under Q193221

SYMPTOMS

When you use Performance Monitor to monitor the throughput of a system, the following counters do not work when you upgrade a server from Exchange Server version 4.0:

  • Receive msgs/sec
  • Send msgs/sec
  • Receive bytes/sec
  • Send bytes/sec

CAUSE

This issue is caused by a bug introduced in the message transfer agent (MTA) in versions 5.0 and 5.5.

RESOLUTION

Exchange Server 5.5

To resolve this problem, obtain the latest service pack for Exchange Server version 5.5. For more information, please see the following article in the Microsoft Knowledge Base:

191014 XGEN: How to Obtain the Latest Exchange Server 5.5 Service Pack


The English version of this fix should have the following file attributes or later:

Component: Message Transfer Agent

   File Name      Version
   -------------------------
   Dbserver.sch   5.5.2331.0
   Dcprods.cat    5.5.2331.0
   Ems_rid.dll    5.5.2331.0
   Emsmta.exe     5.5.2331.0
   Info4log.cfg   5.5.2331.0
   Infodlog.cfg   5.5.2331.0
   Infollog.cfg   5.5.2331.0
   Infotlog.cfg   5.5.2331.0
   Mtacheck.exe   5.5.2331.0
   Mtamsg.dll     5.5.2331.0
   P2.xv2         5.5.2331.0
   X400om.dll     5.5.2331.0
   X400omv1.dll   5.5.2331.0
				

STATUS

Microsoft has confirmed this to be a problem in Microsoft Exchange Server versions 5.0 and 5.5. This problem was first corrected in Exchange Server 5.5 Service Pack 2.


Modification Type:MinorLast Reviewed:4/21/2005
Keywords:kbbug kbfix kbQFE KB193221