Problems After Enabling Active Desktop (193110)
The information in this article applies to:
- Microsoft Internet Explorer 4.01 for Windows 95
- Microsoft Internet Explorer 4.0 for Windows 95
- the operating system: Microsoft Windows 98
- the operating system: Microsoft Windows 98 Second Edition
This article was previously published under Q193110 SYMPTOMS
When you enable Active Desktop, you may experience one or more of the
following symptoms:
CAUSE
This behavior can occur if the Mshtml.dll file is missing or damaged, or
if the registry entries for the Mshtml.dll file are missing or damaged.
RESOLUTION
To resolve this behavior, follow these steps:
- Click Start, point to Find, and then click Files Or Folders.
- In the Named box, type mshtml.dll, and then
click Find Now.
- If the Mshtml.dll file is found, right-click it, click Rename, and then
type a new name for the Mshtml.dll file (such as Mshtml.xxx).
If the Mshtml.dll file is not found, skip to step 4.
For more information about how to rename a file, click Start, click
Help, click the Index tab, type renaming,
and then double-click the "Renaming Files" topic.
- Quit the Find tool.
- Extract a new copy of the Mshtml.dll file from your original Internet
Explorer CD-ROM, the folder to which you downloaded the Internet
Explorer Setup files, or your original Windows 98 disks or CD-ROM to
the Windows\System folder.
NOTE: If you do not have an Internet Explorer CD-ROM or a folder on
your hard disk that contains the Internet Explorer Setup files, contact
Microsoft Product Support Services.
NOTE: If you previously applied an update to the Mshtml.dll file
provided by Microsoft, reinstall the updated version of the Mshtml.dll
file instead of the version included with Internet Explorer or Windows
98.
In Internet Explorer 4.0 or 4.01 for Windows 95, follow these steps to
extract the Mshtml.dll file:
- At a command prompt, type the following command, and then press
ENTER
extract /l <path1> <path2>\ie4_s2.cab ie4_2.cab
where <path1> is the path to the folder to which you want to extract
the Ie4_2.cab cabinet file, and <path2> is the path to the folder in
which the Internet Explorer Setup files are located.
NOTE: If you downloaded Internet Explorer 4.0 or 4.01 from the
Internet, <path2> is location of the Internet Explorer Setup files
on your hard disk. If you installed Internet Explorer 4.0 or 4.01
from a CD-ROM, <path2> is the path to the Internet Explorer Setup
files on your Internet Explorer 4.0 or 4.01 CD-ROM.
- At the command prompt, type the following command, and then press
ENTER
extract /l <path1> <path2>\ie4_2.cab mshtml.dll
where <path1> is the location of the Windows\System folder,
and <path2> is the path to the folder to which you extracted the
Ie4_2.cab file.
In Windows 98, use the System File Checker tool to extract the
Mshtml.dll file. For information about how to extract files using the
System File Checker tool, please see the following article in the
Microsoft Knowledge Base:
ARTICLE-ID: 129605
TITLE : How to Extract Original Compressed Windows Files
If the behavior persists, follow these steps:
- Click Start, and then click Run.
- In the Open box, type "regsvr32 /i mshtml.dll" (without quotation
marks), click OK, and then click OK again.
- Restart your computer.
Modification Type: | Major | Last Reviewed: | 12/8/2003 |
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Keywords: | kbenv kberrmsg kbprb KB193110 |
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