System File Checker Tool Extracts Incorrect File Versions (192832)
The information in this article applies to:
This article was previously published under Q192832
If this article does not describe the error message that you are receiving, view the following Microsoft Knowledge Base article to view more articles that describe error messages:
315854 Windows 98 and Windows Me Error Message Resource Center
SYMPTOMS
When you use the System File Checker (Sfc.exe) tool to restore a Windows 98 system file (for example, the User.exe, Gdi.exe, Setupx.dll or Krnl386.exe file) from a Windows 98 cabinet (.cab) file, the wrong version of the file may be extracted from the Mini.cab cabinet file. This can result in the inability to start Windows 98 (for example, your computer may stop responding) or "Windows Protection Error" error messages in normal and Safe mode.
NOTE: This symptom can occur when the System File Checker tool prompts you to restore a corrupt system file during a scan or when you extract and replace a system file using the System File Checker tool.
CAUSE
This behavior occurs because the System File Checker tool baseline file
(Default.sfc) contains incorrect information about the source cabinet
file locations for some Windows 98 system files. As a result, the System
File Checker tool searches for the system file in the specified folder
(if it is not in a cabinet file) and then in all cabinet files in the
specified folder. The System File Checker tool searches cabinet files
using their MS-DOS folder order and extracts the first instance found. If
the Mini.cab cabinet file appears in an MS-DOS folder listing before the
correct Windows 98 cabinet file (for example, the correct cabinet file
for the User.exe file is the Win98_42.cab cabinet file.), the System File
Checker tool may find the mini-Windows mode version of the system file in
the Mini.cab cabinet file first.
NOTE: The Mini.cab cabinet file contains mini-Windows mode files used only by Windows 98 Setup and DriveSpace.
RESOLUTION
To work around this behavior, restart your computer using the Windows 98 Startup disk, choose Start Computer With CD-ROM Support from the Windows 98 Startup menu, and then re-extract the file at a command prompt using the Extract.exe tool. For additional information about how to extract a file, click the article number below
to view the article in the Microsoft Knowledge Base:
129605 How to Extract Original Compressed Windows Files
NOTE: The Extract.exe tool does not search the Mini.cab cabinet file by default.
Alternately, if you selected the option to back up the existing file when you used SFC to extract the incorrect version of the file, you can restore the backup of the file from the Windows\Helpdesk folder or from the folder that you specified for the backup.
STATUS
This issue is fixed in Microsoft Windows 98 Second Edition.
Modification Type: | Minor | Last Reviewed: | 12/16/2004 |
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Keywords: | kbprb kbWinProtectErr KB192832 |
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