FP97: No Documents Found After Performing Search Query (192434)
The information in this article applies to:
- Microsoft FrontPage 97 for Windows with Bonus Pack
This article was previously published under Q192434 For a Microsoft FrontPage 2000 version of this article, see 205710.
For a Microsoft FrontPage 98 version of this article, see 194047.
SYMPTOMS
When you perform a search, no results are returned and you may receive
the following message:
No documents found. Please try again.
CAUSE
This message may appear if any of the following are true:
- The files that contain the index information for the search component
are corrupted or missing (for example, they were deleted or moved).
-or-
- If you are publishing to a web that uses Microsoft Index Server, the
catalog file does not exist.
-or-
- You are searching for a word that is on the WAIS stop list.
RESOLUTION
To resolve this behavior, use one of the following methods.
NOTE: You should try Method 1 first. If Method 1 does not resolve this
behavior, use Method 2. If you are using Microsoft Index Server, use
Method 3.
Method 1: Recalculate Links- Start FrontPage Explorer and open your Web.
- On the Tools menu, click Recalculate Hyperlinks.
- Rerun your search in a Web browser.
NOTE: You may need to refresh or reload the page in the Web browser.
Method 2: Reset the Dependency Databases
To reset the dependency databases used by the WebBot Search
Component, follow these steps:
- In Windows Explorer, open the folder that contains your Web content.
To determine where your content is stored, use the following table as
a guide.
NOTE: The folders listed in the table are the default folders created
when you install FrontPage. If you configured your Web server to use
a different content root, select that folder instead of the one
listed in the table.
Web Server Folder
---------------------------------------------------------------
FrontPage Personal Web Server \FrontPage Webs\Content
Microsoft Personal Web Server \Webshare\Wwwroot
Microsoft Internet Information Server \InetPub\Wwwroot
- Open the folder that contained the deleted page.
- Open the \_vti_pvt folder and delete the following two files:
Deptodoc.btr
Doctodep.btr
- Open the \_vti_txt\default.wti folder. Delete the following files:
All.cat
All.dct
All.doc
All.fmt
All.fn
All.hl
All.idx
All.inv
All.src
- Switch to FrontPage Explorer.
- On the Tools menu, click Recalculate Hyperlinks.
Method 3: Create a Catalog File using Index Server
Set up Index Server with a catalog for the virtual server. For
information about how to do this, please see the following article in
the Microsoft Knowledge Base:
183731 How to Index and Create a Catalog for a New Web Site
Modification Type: | Major | Last Reviewed: | 10/3/2001 |
---|
Keywords: | kbprb kbusage KB192434 |
---|
|