PRB: Error "Cannot Update the File" When You Try to Save a File (192150)
The information in this article applies to:
- Microsoft Visual InterDev 6.0
This article was previously published under Q192150 SYMPTOMS
When you save a file in Visual InterDev, you receive one of the following error messages:
Cannot update the file '<path and filename>'. The web server does not
appear to have any authentication methods enabled. The server has asked
for user authentication but did not send a WWW-Authenticate header.
Cannot update the file '<path and filesname>'. An HTTP error occurred.
The server could not complete your request. Contact your Internet
service provider or Web server administrator to make sure that the
server has the FrontPage Server Extensions installed, and that the Web
application exists on that server.
CAUSE
If Allow Anonymous Access is the only authentication method that is selected for the virtual directory that contains the project, Internet Information Server will not send a WWW-Authenticate header to the client. The WWW-Authenticate header tells the client what types of authentication the server will accept. When you save a file to the Web server in Visual InterDev, authentication is required.
RESOLUTION
Enable one or more authentication methods on the virtual directory that
contains the project. To do this, follow these steps:
- Open the Internet Service Manager.
- Right-click the virtual directory that contains the project.
- On the Directory Security tab, click Edit in Anonymous Access and Authentication Control.
- Select the Basic Authentication check box and/or the Windows NT Challenge/Response check box.
- Click OK to close the Authentication Methods dialog box.
- Click OK to close the directory's Properties dialog box.
STATUS
This behavior is by design.
Modification Type: | Major | Last Reviewed: | 8/22/2001 |
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Keywords: | kbDSupport kbExtension kbide kbprb kbSecurity kbServer KB192150 |
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