PRB: MAPI/CDO (1.x) Applications Fail After Outlook Express 4 Install (192119)



The information in this article applies to:

  • Microsoft Extended Messaging Application Programming Interface (MAPI)
  • Collaboration Data Objects (CDO) 1.0a
  • Collaboration Data Objects (CDO) 1.1
  • Collaboration Data Objects (CDO) 1.2
  • Collaboration Data Objects (CDO) 1.21
  • Microsoft Outlook Express 4.0 for Windows 95
  • Microsoft Outlook Express 4.01 for Windows 95
  • Microsoft Outlook Express 5.0 for Windows 95
  • Microsoft Outlook Express 5.01 for Windows 95
  • Microsoft Outlook Express 5.5 for Windows 95
  • Microsoft Outlook Express 4.0 for Windows NT 4.0
  • Microsoft Outlook Express 4.01 for Windows NT 4.0
  • Microsoft Outlook Express 5.0 for Windows NT 4.0
  • Microsoft Outlook Express 5.01 for Windows NT 4.0
  • Microsoft Outlook Express 5.5 for Windows NT 4.0
  • Microsoft Outlook Express 6.0 for Windows NT 4.0

This article was previously published under Q192119

SYMPTOMS

Some customers may encounter challenges with their Extended Messaging Application Programming Interface (MAPI) and/or Collaboration Data Object (1.x) based applications no longer functioning after installing Outlook Express 4.X.

CAUSE

During setup, if the option to make Outlook Express 4.X your default e-mail application is selected, Outlook Express 4.X renames the existing Mapi32.dll on the system to Mapi32.oe, then installs and register its own MAPI DLLs to replace the previous MAPI subsystem.

The MAPI DLLs installed by Outlook Express 4.X include only Simple MAPI, not both Simple and Extended MAPI like the Mapi32.dll installed by Exchange Server, Exchange Client, Windows Messaging, and the full Outlook Client.

RESOLUTION

To restore the full MAPI subsystem, clear the "Make Outlook Express my default Simple MAPI client" check box by following these steps:
  1. In Outlook Express 4.X, from the Tools menu, choose Options.
  2. Click the General tab, and clear the "Make Outlook Express my default Simple MAPI client" check box.
  3. Click OK, and then click OK again.
  4. Restart your system.

STATUS

This behavior is by design.

REFERENCES

For additional information, please see the following article in the Microsoft Knowledge Base:

174664 Microsoft Exchange Does not Start


Modification Type:MinorLast Reviewed:8/25/2005
Keywords:kbFAQ kbMsg kbprb KB192119