OL98: Error Message: You Do Not Have the Correct Version (191778)



The information in this article applies to:

  • Microsoft Outlook 98

This article was previously published under Q191778
IMPORTANT: This article contains information about editing the registry. Before you edit the registry, make sure you understand how to restore it if a problem occurs. For information about how to do this, view the "Restoring the Registry" Help topic in Regedit.exe or the "Restoring a Registry Key" Help topic in Regedt32.exe.

SYMPTOMS

When installing the Security Patch for Microsoft Outlook, you may receive either of the following error messages:
You do not have the correct version of Microsoft Outlook. This patch is intended for Microsoft Outlook 98.
-or-
You must have installed Microsoft Outlook to use this patch

CAUSE

This error message may occur when either of the following conditions are true:

  • You are trying to install the patch onto Outlook 97 -or-

  • You have both Microsoft Outlook 97 and Microsoft Outlook 98 installed on the same computer, and Outlook 97 is installed in the default location. -or-

  • You are attempting to run the patch on a prerelease, beta version of Outlook 98.

MORE INFORMATION

The security patch is designed to work with Outlook 98, not Outlook 97. If you had installed Outlook 97, and then install Outlook 98 into a different folder, it is possible that Outlook 97 was not updated and not removed from the computer. This could be due to a corrupted registry, or other reasons that are beyond the scope of this article.

Outlook 98 and Outlook 97 are not designed to coexist on the same computer. However there are times where, through no fault of your own, Outlook 98 is installed without upgrading Outlook 97. When deciding the best option for your situation, you need to use your own judgment.

When the security patch runs, the first thing it does is to look at a registry entry that tells it where Outlook is installed. It then goes to the program at the location identified by the patch and checks the version of Outllib.dll.

If the version is not Outlook 98 (8.5), you receive the following error message:
You do not have the correct version of Microsoft Outlook. This patch is intended for Microsoft Outlook 98.
If the program is not at the location specified in the registry entry, you receive following error message:
You must have installed Microsoft Outlook to use this patch.
To verify your version of Outlook prior to installing the patch, follow these steps:
  1. In Outlook, click About Microsoft Outlook on the Help menu.
  2. Ensure that the version number in the upper right of the About Microsoft Outlook window is 8.5.5104.6

Troubleshooting Tips

To troubleshoot this problem, follow these steps:
  1. Check to see if Outlook 97 exists on the computer.
  2. Check Add/Remove Programs in Control Panel.
  3. Check and/or edit the App Paths registry subkey to make sure Outlook 98 is installed to the same location as is noted in the registry.

Check to See If Outlook 97 Exists on the Computer

  1. Click Start, point to Find, and then click Files Or Folders.
  2. Type outllib.dll, and click to select My Computer in the Look In list. Click Find Now, to start the search.
  3. After the file(s) have been found, right-click the file name and then click Properties on the shortcut menu.
  4. On the Version tab, look to see if the File Version is 8.5 or higher. If it is not, then you are running Outlook 97.
  5. If you have multiple copies of Outllib.dll, check the version of each copy. This is also an indication that you may have multiple, versions of Outlook installed. Note the path of each copy.

Check Add/Remove Programs in Control Panel

  1. Click Start, point to Settings, and then click Control Panel.
  2. Double-click the Add/Remove Programs icon.
  3. On the Install/Uninstall tab, check if Microsoft Outlook 98 is listed. If it is not, you need to run Setup to install Outlook 98 again.

    NOTE: You may need to remove Outlook 97 first, and then install Outlook 98.

Check and/or Edit the App Paths Registry Key

WARNING: Using Registry Editor incorrectly can cause serious problems that may require you to reinstall your operating system. Microsoft cannot guarantee that problems resulting from the incorrect use of Registry Editor can be solved. Use Registry Editor at your own risk.

For information about how to edit the registry, view the "Changing Keys And Values" Help topic in Registry Editor (Regedit.exe) or the "Add and Delete Information in the Registry" and "Edit Registry Data" Help topics in Regedt32.exe. Note that you should back up the registry before you edit it. If you are running Windows NT, you should also update your Emergency Repair Disk (ERD).

When the Security Patch starts, it looks in the registry at the following subkey for the installed location of Outlook 98:

NOTE: (HKLM stands for HKEY_LOCAL_MACHINE)

HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\App Paths\OUTLOOK.EXE

  1. Click Start, and then click Run. Type "regedit" (without the quotation marks) and then click OK.
  2. Navigate to the OUTLOOK.EXE registry subkey using the path above.
  3. In the right pane, click to select Path. On the Edit menu, click Modify.
  4. Note the information in the String Value box. If it does not match the actual path where Outlook 98 is installed, click in the box and edit to correct the string value. Click OK to close the dialog box.
  5. Quit the registry editor and restart the computer.

REFERENCES

For more information about the Outlook Security Patch, please see the following article in the Microsoft Knowledge Base:

175807 OL98: Update Available for Outlook 98 Security Issue


Modification Type:MajorLast Reviewed:5/26/2001
Keywords:kb3rdparty kberrmsg kbprb KB191778