Disk Activity May Interfere with USB Devices (191721)



The information in this article applies to:

  • Microsoft IntelliMouse USB
  • Microsoft SideWinder Precision Pro
  • the operating system: Microsoft Windows 98
  • Microsoft SideWinder Force Feedback Wheel USB

This article was previously published under Q191721

SYMPTOMS

When your computer reads from the hard disk, floppy drive, or CD-ROM drive, Universal Serial Bus (USB) devices may not function properly.

You may experience any of the following symptoms:

  • The IntelliMouse USB pointer may move slowly, behave erratically, or stop responding (hang).
  • The SideWinder Precision Pro joystick may behave erratically or stop responding (hang).

CAUSE

This behavior can occur if the disk activity requires a significant amount of processor resources.

RESOLUTION

You may be able to resolve this issue by assigning the drive a Direct Memory Access (DMA) resource setting. To do this, follow these steps:

  1. Click Start, point to Settings, and then click Control Panel.
  2. Double-click System.
  3. Click the Device Manager tab.
  4. Double-click CD-ROM or Disk Drives.
  5. Double-click the drive that is interfering with the USB device.
  6. On the Settings tab, click to select the DMA check box.
  7. Click OK, and then follow the instructions on the screen. If you are prompted to restart the computer, do so.

STATUS

Microsoft has confirmed this to be a problem in the Microsoft products listed in the applies to section of this article.

MORE INFORMATION

USB signals and loading a program or retrieving data from a disk both require processor resources. The processor overhead created by accessing the disk may cause the processor to not execute the USB device signals properly. Assigning a DMA channel to the disk provides a mechanism for data transfer that does not require monitoring by the processor. Freeing the processor resources required by disk access may allow the processor to execute the USB signals properly.

WARNING: Assigning multiple DMA channels may cause hardware conflicts on your computer. Contact the computer manufacturer for more information regarding your system configuration.

Modification Type:MinorLast Reviewed:8/18/2005
Keywords:kbenv kbHardware kbprb KB191721