Upgrading Host Security Files May Cause Corrupted Database (191696)



The information in this article applies to:

  • Microsoft SNA Server 4.0 SP1

This article was previously published under Q191696

SYMPTOMS

Upgrading SNA Server 4.0 Service Pack 1 Host Security files (from the HOSTSEC directory) may cause corruption to the Host Account Database (DBase.dbs). When the database becomes corrupted, it may prevent users from using the Single Sign-On (SSO) feature, also known as automatic logon. Other symptoms may be that the Host Account Cache service (SNADATABASE) stops responding to RPC requests.

The application log of the event viewer shows the following two events coming from source SNA Host Security, after SP1 is upgraded.
Event ID 1247 - Unable to decrypt data Supplied code 0x80090005

Event ID 1283 - Database has been corrupted - contact system support
Supplied code 0x1

CAUSE

The cause is not currently known but is under investigation.

WORKAROUND

To work around this problem, you can remove and reinstall the Host Security components. Because a removal is required, the Host Security Database must be repopulated again, either by using the Host Account Manager (UDConfig.exe) or by using the command-line utility SNACFG.

Modification Type:MinorLast Reviewed:2/11/2004
Keywords:kbprb KB191696