The DirectDraw option or the Direct3D option is unavailable when you start Microsoft games for Windows (191660)



The information in this article applies to:

  • Flight Simulator X Deluxe
  • Flight Simulator X Standard
  • Links 2003 Championship Edtn EN
  • Microsoft Age of Empires III
  • Microsoft Age of Empires III Expansion: The War Chiefs
  • Microsoft Age of Mythology
  • Microsoft Age of Mythology: The Titans
  • Microsoft Age of Mythology: Gold Edition
  • Microsoft Combat Flight Simulator 3: Battle for Europe
  • Microsoft Dungeon Siege 1.0
  • Dungeon Siege: Legends of Aranna
  • Microsoft Dungeon Siege II
  • Microsoft Fable: The Lost Chapters PC
  • Microsoft Flight Simulator 2002
  • Microsoft Flight Simulator 2002 Professional Edition
  • Microsoft Flight Simulator 2004 - Century of Flight
  • Microsoft Freelancer
  • Microsoft Impossible Creatures
  • Microsoft Links 2003
  • Microsoft Links 2003 Championship Edition
  • Microsoft MechWarrior 4: Black Knight
  • Microsoft MechWarrior 4: Clan 'Mech Pak
  • Microsoft MechWarrior 4: Inner Sphere 'Mech Pak
  • Microsoft MechWarrior 4: Vengeance
  • Microsoft Plus! 98
  • Microsoft Rise of Nations
  • Microsoft Rise of Nations: Gold Edition
  • Microsoft Rise of Nations: Rise of Legends
  • Microsoft Rise of Nations: Thrones and Patriots

This article was previously published under Q191660

SYMPTOMS

When you try to start one of the games listed in the "Applies to" section, you may experience one of the following symptoms:
  • The 3D Acceleration option may be unavailable.
  • You may receive an error message that states that your video adapter does not meet the game requirements.
  • You may receive an error message that states that your video adapter does not have the 3D Acceleration option.
  • The DirectX Diagnostic Tool (Dxdiag.exe) shows Approx. Total Memory as blank or N/A.
  • The DirectX Diagnostic Tool (Dxdiag.exe) shows the DirectDraw option or the Direct3D option as unavailable.

CAUSE

This issue may occur for any one of the following reasons:
  • Your computer does not meet the minimum 3D hardware requirements to run the game.
  • Your video adapter does not have sufficient video memory to run the game.
  • DirectDraw Acceleration is disabled.
  • You are using out-of-date drivers for your video adapter.
  • The latest version of DirectX is not installed or is damaged.
  • One or more programs that are running in the background are interfering with the game.

RESOLUTION

To resolve this issue, use the following methods in the order that they appear in.

Note Because there are several versions of Microsoft Windows, the following steps may be different on your computer. If they are, see your product documentation to complete these steps.

Method 1: Configure Hardware Acceleration to use the Full setting

To do this, follow these steps:
  1. Click Start, and then click Control Panel.
  2. Double-click Display.

    If you do not see Display, click Switch to Classic View.
  3. Click the Settings tab, and then click Advanced.
  4. On the Performance or on the Troubleshooting tab, move the Hardware Acceleration slider all the way to the right (the Full position).
  5. Click OK, and then click Close.
  6. If you are prompted to restart your computer, click Yes.
Configure Hardware Acceleration to use the Full setting
If your computer meets the minimum system requirements, use the following methods to work around this issue.

Method 2: Enable DirectDraw or Direct3D

To enable DirectDraw or Direct3D, run the DirectX Diagnostic Tool (Dxdiag.exe). To do this, follow these steps:
  1. Click Start, click Run, type dxdiag in the Open box, and then click OK.
  2. On the Display tab, under DirectX Features, verify that DirectDraw Acceleration and Direct3D Acceleration are selected.

    If either of these lines shows a Disabled status, click Enable for that line.
  3. If multiple video adapters are installed in your computer, repeat steps 3 and 4 for each Display tab in the DirectX Diagnostic Tool.
Click the Play button to view this streaming media demonstration.


If the issue continues to occur, go to the next method.

Method 3: Download and install the latest version of DirectX End-User Runtimes Web Installer

To do this, visit the following Microsoft Web site:Note You may receive the following error message during installation:
The software you are installing has not passed Windows Logo testing to verify its compatibility with this version of Windows. (Tell me why this testing is important.)
For more information, click the following article number to view the article in the Microsoft Knowledge Base:

822798 You cannot install some updates or programs

If the issue continues to occur, go to the next method.

Method 4: Update your video driver

To see whether applicable driver updates are available, visit the following Microsoft Windows Update Web site: For information about how to contact the video hardware manufacturer, click the appropriate article number in the following list to view the article in the Microsoft Knowledge Base:

65416 Hardware and software vendor contact information, A-K

60781 Hardware and software vendor contact information, L-P

60782 Hardware and software vendor contact information, Q-Z

Microsoft provides third-party contact information to help you find technical support. This contact information may change without notice. Microsoft does not guarantee the accuracy of this third-party contact information. If the issue continues to occur, go to the next method.

Method 5: Restart the computer by using a clean boot procedure

When you start Microsoft Windows, typically there are several programs that start automatically and run in the background that may interfere with the game. These programs may include antivirus and system utility programs. When you perform a clean boot procedure, you prevent these programs from starting automatically.

You must be logged on as an administrator or a member of the Administrators group to complete this procedure. If your computer is connected to a network, network policy settings may also prevent you from completing this procedure.

To restart the computer by using a clean boot procedure, follow these steps if you are using Microsoft Windows XP.

Note You may experience a temporary loss of some services functionality when you follow these steps. Restoring the settings restores the functionality. But the original error message or behavior may return.
  1. Click Start, click Run, type msconfig in the Open box, and then click OK.
  2. On the General tab, click Selective Startup.
  3. Under Selective Startup, click to clear the following check boxes:
    • Process SYSTEM.INI File
    • Process WIN.INI File
    • Load Startup Items
  4. On the Services tab, click to select the Hide All Microsoft Services check box, and then click Disable All.
  5. Click OK, and then click Restart.
Click Play to view this streaming media demonstration.




For more information or to view steps for other operating systems, click the following article number to view the article in the Microsoft Knowledge Base:

331796 Games: How to perform a clean boot to prevent background programs from interfering with play

If the issue continues to occur, go to the next method.

Method 6: Disable NetMeeting's Remote Desktop Sharing and then close NetMeeting

Microsoft Windows NetMeeting disables Direct3D when Remote Desktop Sharing is enabled. To disable NetMeeting's Remote Desktop Sharing feature, follow these steps:
  1. Start NetMeeting.
  2. On the Tools menu, click Remote Desktop Sharing.
  3. Click to clear the Enable Remote Desktop Sharing on this computer check box.
  4. Click OK.
  5. Close NetMeeting.
If the issue continues to occur, go to the next method.

Method 7: Disable the Enable Write Combining feature in Microsoft Windows XP

To disable the Enable Write Combining feature, follow these steps:
  1. Click Start, click Control Panel, and then double-click Display.
  2. On the Settings tab, click Advanced, and then click the Troubleshoot tab.
  3. Click to clear the Enable Write Combining check box.
  4. Click OK, and then click OK again.
  5. If the issue is not resolved, repeat steps 1 through 4, but in step 4 click to select the Enable Write Combining check box.
Start the game. If these steps were not successful, go to the next method.

Method 8: Create a new user account in Windows XP

To create a user account on a Microsoft Windows XP-based computer, follow these steps:
  1. Click Start, click Run, type compmgmt.msc, and then click OK.
  2. Expand Local Users and Groups, right-click Users, and then click New User.
  3. In the User name field, type UserName.
  4. In the Password field and in the Confirm password field, type UserPassword, and then click Create.

    Important Passwords are case-sensitive. For example, MyPassword and mypassword are treated as two different passwords.
  5. Double-click the newly created user account, click the Member Of tab, click Add to add the user to a proper group, and then click OK.

    Note Some games require an account in the Administrators group to run.

MORE INFORMATION

For more information, click the following article number to view the article in the Microsoft Knowledge Base:

263039 How to troubleshoot display issues in Microsoft games


Modification Type:MajorLast Reviewed:10/8/2006
Keywords:kbhowto kbArtTypeSHOWME kbdisplay kbenv kberrmsg kbinterop kbprb KB191660 kbAudEndUser