Internet Explorer Does Not Save Connection Settings (191451)



The information in this article applies to:

  • Microsoft Internet Explorer 4.01 for Windows NT 4.0 SP 1
  • Microsoft Internet Explorer 4.01 for Windows NT 4.0 SP 2
  • Microsoft Internet Explorer 4.0 for Windows NT 4.0
  • Microsoft Internet Explorer 3.02 for Windows NT 4.0
  • Microsoft Internet Explorer 4.01 for Windows 95 SP 1
  • Microsoft Internet Explorer 4.01 for Windows 95 SP 2
  • Microsoft Internet Explorer 4.0 for Windows 95
  • Microsoft Internet Explorer 3.02 for Windows 95
  • the operating system: Microsoft Windows 98

This article was previously published under Q191451
IMPORTANT: This article contains information about modifying the registry. Before you modify the registry, make sure to back it up and make sure that you understand how to restore the registry if a problem occurs. For information about how to back up, restore, and edit the registry, click the following article number to view the article in the Microsoft Knowledge Base:

256986 Description of the Microsoft Windows Registry

SYMPTOMS

When you start Internet Explorer, your modem may not dial your Internet service provider (ISP), and you may receive the following error message:
Internet Explorer could not open the Internet site http://Web address

A connection to the server could not be established.
In Windows NT 4.0, you may receive the following error message:
TsAdBot.exe-DLL Initialization failed

Initialization of the dynamic link library C:\WinNT\System32\wininet.dll failed. The process is terminating abnormally.
If you check your connection settings by clicking Internet Options on the View menu and then clicking the Connection tab, you may notice that the "Connect to the Internet using a modem" option is disabled and the "Connect to the Internet using a local area network" option is enabled. Changing these settings and then restarting Internet Explorer or your computer does not resolve this behavior.

CAUSE

This behavior can occur if PKWare PKZip for Windows version 2.60.01 (shareware version) is installed, and the Tsadbot.exe program is running.

RESOLUTION

WARNING: If you use Registry Editor incorrectly, you may cause serious problems that may require you to reinstall your operating system. Microsoft cannot guarantee that you can solve problems that result from using Registry Editor incorrectly. Use Registry Editor at your own risk.

To work around this behavior, use either of the following methods:

Method 1

  1. Press CTRL+ALT+DELETE to open the Close Program dialog box, click Tsadbot, click End Task, and then quit Task Manager.
  2. Click Start, point to Find, and then click Files Or Folders.
  3. In the Named box, type tsadbot.exe, and then click Find Now.
  4. In the list of found files, right-click the Tsadbot.exe file, click Rename, type a new name for the file (such as Tsadbot.xxx), and then press ENTER.
  5. Quit the Find tool.

Method 2

NOTE: This method prevents the connection settings from being changed only when you start your computer. They are still changed when you run PKZip.

Using Registry Editor, delete the following registry key:

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Run\TimeSink Ad Client

MORE INFORMATION

Some versions of PKZip include the Tsadbot.exe program. This program displays advertisements for various Web sites, and is run every time you start your computer or PKZip.

The third-party products that are discussed in this article are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, regarding the performance or reliability of these products.

Modification Type:MajorLast Reviewed:12/8/2003
Keywords:kb3rdparty kberrmsg kbprb KB191451