OL98: (IMO) Error Message: "Internet Mail Not Registered" or Error Code 08x80040154 (191423)



The information in this article applies to:

  • Microsoft Outlook 98

This article was previously published under Q191423
NOTE: These procedures only apply if you have installed Outlook with the Internet Mail Only option. To determine your installation type, click About Microsoft Outlook on the Help menu. If you have the Internet Mail Only option installed, you see "Internet Mail Only".

For information about the differences between Microsoft Outlook and Microsoft Outlook Express e-mail clients, click the following article number to view the article in the Microsoft Knowledge Base:

257824 OL2000: Differences Between Outlook and Outlook Express

SYMPTOMS

You are using Microsoft Outlook 98 as your mail client. When you attempt to send and receive mail, you receive the following error message:
Internet Mail is not Registered Properly. Please Reinstall and try again.
Additionally, details from the Account status dialog box may list error code, 0x80040154

CAUSE

This error message may occur when either of the following conditions are true:
  • The Outlmime.dll file, which is a critical file involved in the mail transfer process, is not registered correctly.
  • The wrong version of the Inetcomm.dll file is installed.

RESOLUTION

Verify that you have Inetcomm.dll version 4.72.3155.0 if you use Microsoft Windows 98 or Microsoft Windows NT 4.0. If you use Microsoft Windows 95, the correct version is 4.72.2106.4. If you have any other version, rename it, and then reinstall Microsoft Internet Explorer 4.01.

NOTE: Although the following steps apply to Internet Explorer as it is installed with Outlook 98, the same procedures apply if you are using Microsoft Internet Explorer 5.0. The version of Inetcomm.dll should be 5.00.2314.1003. If the version is earlier than this, rename the Inetcomm.dll file, and install Internet Explorer 5.0 from the following Microsoft Web site: The steps in this article only apply to Internet Explorer 4.01.

NOTE: If you installed Outlook from a CD-ROM, you can extract the file from the Mailnews.cab file, located in the En\Ol98 folder.

Additionally, you can extract the file from the Mailnews.cab file located on the Internet Explorer CD-ROM.

For additional information about extracting files from a .cab file, please click the article number below to view the article in the Microsoft Knowledge Base:

129605 How to Extract Original Compressed Windows Files

To verify the version of Inetcomm.dll:
  1. Quit all programs, click Start, point to Find, and click Files or Folders.
  2. In the Named box, type Inetcomm.dll. Click to select the C drive in Look In, click Include Subfolders, and then click Find Now.
  3. Right-click the file in the Results pane, click Properties, and then click the Version tab. The file version is near the top of this tab. Make a note of the version number, and then click Cancel.
  4. If you do not have the correct version, right-click the file name in the results pane, and then click Rename.
  5. Click the insertion point at the end of the filename, press the BACKSPACE key to backspace over "dll," type old, and then press ENTER.
  6. Close Find Files, and then reinstall Internet Explorer.
Choose one of the following methods to register Outlmime.dll.

Method 1: Windows 98

  1. Click Start, point to Settings, and then click Control Panel.
  2. Double-click Add/Remove Programs.
  3. On the Windows Setup tab, click Microsoft Outlook Express, and then click OK to uninstall it.
  4. After Outlook Express is uninstalled, repeat steps one through three to reinstall it.

Method 2: Windows 95 or Windows 98

These steps assume that you installed Outlook in the Microsoft Office 97 default installation path.

To resolve this error message:
  1. Quit Outlook and any other programs that are currently running. Click Start, point to Programs, and then click MS-DOS Prompt.
  2. In the MS-DOS Prompt window, type (include quotation marks):

    cd "\program files\microsoft office\office"

    and then press ENTER.
  3. In the MS-DOS Prompt window, type:

    c:\windows\system\regsvr32 outlmime.dll

    and then press ENTER.

    You receive the following message:

    DllRegisterServer in outlmime.dll succeeded.

    Click OK, and then click Close to close the MS-DOS prompt window.

    NOTE: See the "More Information" section if you have problems with this step.
  4. Start Outlook, and then send a mail message to test your mail functionality.

Method 3: Microsoft Windows NT 4.0

  1. Quit Outlook and any other programs that are currently running. Click Start, point to Programs, and then click Command Prompt.
  2. In the Command Prompt window, type (include quotation marks):

    "cd\program files\microsoft office\office"

  3. In the Command Prompt window, type:

    c:\winnt\system32\regsvr32 outlmime.dll

    You receive the following message:

    DllRegisterServer in outlmime.dll succeeded.

    Click OK, and then click Close to close the Command Prompt window.

    NOTE: See the "More Information" section of this article if you have problems with this step.
  4. Start Outlook, and then send a mail message to test your mail functionality.

MORE INFORMATION

In step 3 of Method 2 and Method 3, you may need to enter the full path to the System folder in Windows 95 or Windows 98, or to the System32 folder in Windows NT.

For Windows 95 or Windows 98, the typical command line is:

c:\windows\system\regsvr32 outlmime.dll

For Windows NT, the typical command line is:

c:\winnt\system32\regsvr32 outlmime.dll

To display the full system path:
  1. Click Start, point to Programs, and then click MS-DOS Prompt in Windows 95 or Windows 98, or Command Prompt in Windows NT.
  2. In the MS-DOS Prompt or Command Prompt window, type Set, and then press ENTER. The line that begins with PATH defines the full system path.

Modification Type:MajorLast Reviewed:4/19/2001
Keywords:kberrmsg kbprb KB191423