WD98: English Text with Japanese or Chinese Wraps After a Space (190671)



The information in this article applies to:

  • Microsoft Word 98 Macintosh Edition

This article was previously published under Q190671

SYMPTOMS

When you use Japanese or Chinese characters in Microsoft Word 98 Macintosh Edition, you may experience the following problems:
A line of text that contains first an English word, followed by a space, and is then followed by Japanese or Chinese characters, will wrap directly after the space.

-or-

Occasionally, Word will start a Japanese or Chinese line with punctuation, like a period or comma

CAUSE

Though the English version of Word 98 allows the input and editing of Japanese and Chinese text with the appropriate language kit from Apple, Word 98 treats the Japanese and Chinese characters as if they are English words. Japanese and Chinese word processing does not include spaces between words. So, where the Japanese or Chinese text begins, Word considers that text to be one long word and wraps it to the next line. Word does this because the text can't fit on the first line.

RESOLUTION

If you want to use a full-featured version of Word to process Japanese or Chinese characters, use the Japanese or Chinese version of Word 98.

To obtain pre-sales information about new or updated Microsoft products, call the Microsoft Sales Information Center at (800) 426-9400. If you are outside the United States, contact the Microsoft subsidiary for your area. To locate your subsidiary, see the Microsoft World Wide Offices Web site at: To work around this behavior, use the Find and Replace function to change all spaces to non-breaking spaces. To do this, follow these steps:

  1. On the Edit menu, click Replace.
  2. In the Find What box, press the SPACEBAR once.
  3. Click in the Replace With box, and then click the More button.
  4. Click Special and select Nonbreaking Space from the list.
  5. Click Replace All.

    You will see the message "Word has completed its search of the document and has made <number> replacements."
  6. Click OK, and then click Close.

STATUS

Microsoft has confirmed this to be a problem in the Microsoft products listed at the beginning of this article.

Modification Type:MinorLast Reviewed:8/31/2005
Keywords:kbbug kbnofix KB190671