Performance Monitor SNA Adapter Counters Are Missing (190445)
The information in this article applies to:
- Microsoft SNA Server 3.0
- Microsoft SNA Server 4.0
This article was previously published under Q190445 SYMPTOMS
Performance Monitor doesn't show the SNA Server adapter counters even when
SNA Server is started.
NOTE: The SNA Server service must be started in order for the SNA
performance objects to appear within Windows NT performance monitor.
CAUSE
If SNA Server is installed into a directory name that contains spaces, the
SNA Setup program fails to add SNA Server adapter object counters,
regardless of the SNA Server link type being used.
RESOLUTION
Microsoft has confirmed this to be a problem in SNA Server version 4.0 and 4.0 SP1.
This problem was corrected in the latest SNA Server version 4.0 U.S. Service Pack.
For information on obtaining this Service Pack, query on the following word in the
Microsoft Knowledge Base (without the spaces):
S E R V P A C K
WORKAROUND
On computers that do not show the Performance Monitor counters, you can try
using the following procedure to get them installed. The following
procedure can be used to unload and reload the Performance Monitor Counters
for SNA Server and the TN3270 service:
- Open a command prompt on the Windows NT server where SNA Server is
installed.
- Change to the snaroot\System directory (C:\SNA\SYSTEM, by default).
- Type the following at the command prompt and press ENTER to remove the
SNA Server counters:
- Type the following at the command prompt and press ENTER to remove the
TN3270 counters:NOTE: If the counters were correctly installed, these commands will
return text similar to the following:
Removing counter names and explain text for SERVICE NAME.
Updating text for language 009.
If the counters were not correctly installed, these commands will return
text similar to the following:
Counters for SERVICE NAME have not been installed yet.
- Type the following at the command prompt and press ENTER to install the
SNA Server counters:
- Type the following at the command prompt and press ENTER to install the
TN3270 counters:
NOTE: The .ini files contain counters for several languages that may not be
installed on the system. This will result in a large number of error
messages scrolling across the Command Prompt window for each of the
languages not installed. This does not have any adverse effect on the
successful installation of the counters.
Modification Type: | Minor | Last Reviewed: | 4/28/2005 |
---|
Keywords: | kbbug kbpending KB190445 |
---|
|