SBS Unable to Get Name Resolution with DNS (189008)



The information in this article applies to:

  • Microsoft Windows NT Server 4.0
  • Microsoft BackOffice Small Business Server 4.0
  • Microsoft BackOffice Small Business Server 4.0a

This article was previously published under Q189008

SYMPTOMS

Your Windows NT Small Business Server can use Dial-Up Networking to connect to an ISP; however, after connected, you cannot get name resolution from your ISP's DNS server.

When trying to resolve host names to IP addresses, your server may receive the following error message:

Bad IP Address <hostname>

However, you can still ping hosts by IP address.

Additionally the SBS server also may not be able to successfully connect to FTP, HTTP, Telnet resources on the Internet.

CAUSE

WinSock Proxy Client is installed and enabled on the server.

RESOLUTION

To resolve this issue, disable the Winsock Proxy Agent by following these steps:

  1. Click Start, point at Settings, and then click Control Panel.
  2. Double-click the WSP Client icon.
  3. Click to clear the Enable the WinSock Proxy Client check box.
  4. Close the configuration screen and restart the computer.

MORE INFORMATION

The WinSock Proxy Agent is installed and enabled by default in the Windows NT Small Business Server. If you are not using the Proxy server, you should disable this feature.

Modification Type:MajorLast Reviewed:5/14/2003
Keywords:kbprb KB189008