Random Stop 0x50 Errors on Cirrus Video Adapters (188303)



The information in this article applies to:

  • Microsoft Windows NT Server 4.0 Terminal Server Edition
  • Microsoft Windows NT Workstation 4.0
  • Microsoft Windows NT Server 4.0
  • Microsoft Windows NT Server, Enterprise Edition 4.0

This article was previously published under Q188303

SYMPTOMS

On systems with some Cirrus-compatible video adapters, Windows NT may randomly and infrequently stop responding (hang) and report the following blue screen error message:

STOP 0x00000050 error
PAGE_FAULT_IN_NONPAGED_AREA.

CAUSE

The GDI in Windows NT requires 8-byte alignment on the bitmaps it is expected to draw on. Cirrus's driver provides 4-byte alignment instead of 8. This may cause problems on some video adapters where output requests are delivered to GDI.

RESOLUTION

To resolve this problem, obtain the latest service pack for Windows NT 4.0 or Windows NT Server 4.0, Terminal Server Edition. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

152734 How to Obtain the Latest Windows NT 4.0 Service Pack


STATUS

Microsoft has confirmed that this is a problem in Windows NT 4.0 and Windows NT Server 4.0, Terminal Server Edition. This problem was first corrected in Windows NT 4.0 Service Pack 4.0 and Windows NT Server 4.0, Terminal Server Edition Service Pack 4.

Modification Type:MinorLast Reviewed:9/23/2005
Keywords:kbHotfixServer kbQFE kbbug kbfix kbQFE KB188303