Acer FX-3D Sound Card Doesn't Work After Upgrading to Windows 98 (188171)



The information in this article applies to:

  • Microsoft Windows 98
  • Microsoft Windows 98 Second Edition

This article was previously published under Q188171
If this article does not describe your hardware-related issue, please see the following Microsoft Web site to view more articles about hardware:

SYMPTOMS

After you upgrade Microsoft Windows 3.1 to Windows 98, your Acer FX-3D sound card may not work. In addition, you may receive the following error message when you start Windows 98:
Wave Audio Driver
Alert: The driver 15_16W95.vxd is out of date.

CAUSE

This behavior occurs because the Windows 3.1 sound card drivers are still being loaded from the System.ini file. The manufacturer's sound card installation program does not properly remove these drivers.

RESOLUTION

To resolve this behavior, follow these steps to completely remove the Windows 3.1 drivers:
  1. Run the FX-3D uninstall program to remove the Windows 3.1 drivers.
  2. Click Start, point to Settings, and then click Control Panel.
  3. Double-click System, and then click the Device Manager tab.
  4. Double-click the Sound, Video, And Game Controllers branch to expand it, and then click FX-3D or AD1816.

    NOTE: If FX-3D or AD1816 is not listed in the Sound, Video, And Game Controllers branch, check the Other Devices branch.
  5. Click Remove.
  6. Install the Windows 95 drivers using the disk included with your sound card.
NOTE: These steps may be applicable to any AD1816-based sound card.

MORE INFORMATION

Reinstalling the manufacturer-provided Windows 3.1 drivers for the Acer FX-3D sound card does not work because they do not function correctly in Windows 98.

The Acer FX-3D is an Analog Devices AD1816A-based sound card named AcerMagic FX-3D. The FX-3D sound card includes both Windows 3.1 and Windows 95 drivers.

If you perform a clean installation of Windows 98, the sound card is detected as an Analog Devices sound card and is added to the Other Devices branch in Device Manager because Windows does not include drivers for it. In this case, you need to install the manufacturer-provided Windows 95 drivers.



The third-party product discussed in this article is manufactured by a vendor independent of Microsoft; we make no warranty, implied or otherwise, regarding this product's performance or reliability.

Modification Type:MajorLast Reviewed:8/8/2006
Keywords:kb3rdparty kberrmsg kbHardware kbprb KB188171