XADM: Information Store Hangs as Thread CPU Utilization Drops to 0% (187828)
The information in this article applies to:
- Microsoft Exchange Server 5.5
This article was previously published under Q187828 SYMPTOMS
The information store appears to stop responding (hang) frequently, for
short periods of time (most periods not exceeding 5-10 minutes).
CAUSE
The information store queries the directory on a particular public folder
to determine permissions on that folder. The directory is using an
inefficient search filter for this operation and, combined with the context
the store is using to call into the directory, the store threads eventually
block until the initial read is completed.
The problem is aggravated (to the extent you see a hang) by the fact that a
user in the access control list (ACL) for the public folder is a member of
a large number of distribution lists (DLs).
RESOLUTION
A change was made to the ds_search call to use a better filter.
STATUS
Microsoft has confirmed this to be a problem in Microsoft Exchange Server
version 5.5. This problem has been corrected in the latest U.S. service
pack for Microsoft Exchange Server version 5.5. For information on
obtaining the service pack, query on the following word in the Microsoft
Knowledge Base (without the spaces):
Modification Type: | Minor | Last Reviewed: | 9/23/2005 |
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Keywords: | kbHotfixServer kbQFE kbbug kbfix KB187828 |
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