Proxy Fails to Start After Deleting Directory (186675)



The information in this article applies to:

  • Microsoft BackOffice Small Business Server 4.0a
  • Microsoft BackOffice Small Business Server 4.0

This article was previously published under Q186675

SYMPTOMS

After deleting the %homedrive%\SmallBusiness\Clients\MS\Proxy folder, the Proxy services of a Microsoft Small Business Server are unable to start. Following the next restart, an Msphlpr.dll error is given and all Internet Information Server (IIS) services fail.

CAUSE

The Msplat.txt file has the Small Business Server's Proxy Local Address Table (LAT) information in it. This file is contained in the %homedrive%\SmallBusiness\Clients\MS\Proxy folder, and the services will not start without it.

RESOLUTION

If changes have been made to a Small Business Server's LAT table, it should be saved to a safe place before running upgrades or setups.

If the directory is accidentally deleted, after restarting (this is a long process because of the services failing) you may re-create the %homedrive%\SmallBusiness\Clients\MS\Proxy folder. After re-creating this folder, copy the Msplat.txt from the %homedrive%\MSPCLNT directory or from the place where they saved it.

STATUS

Microsoft has confirmed this to be a problem in Microsoft Small Business Server. We are researching this problem and will post additional information here in the Microsoft Knowledge Base as it becomes available.

Modification Type:MajorLast Reviewed:2/24/2004
Keywords:kbbug kbnofix KB186675