NetBEUI May Hang When Using Arcnet Under Heavy Network Traffic (186150)



The information in this article applies to:

  • Microsoft Windows NT Server 4.0 Terminal Server Edition
  • Microsoft Windows NT Workstation 4.0
  • Microsoft Windows NT Server 4.0

This article was previously published under Q186150

SYMPTOMS

When using NetBEUI on an Arcnet network, the NetBEUI protocol may stop responding (hang) after a period of high network activity occurs. The computer has to be restarted to recover from this condition.

CAUSE

NetBEUI keeps a cache of NDIS packets. This means that NetBEUI can send the same packet multiple times. The problem is that NDIS is not clearing out the timeout status bit in the packet descriptor. NDIS maintains a counter that runs about every two seconds. The first pass of the timer, it will set this timeout status on the first packet in the packet queue. The second time the timer runs, it checks to see if this bit is set. If it is, NDIS will reset the adapter. Because NDIS is not resetting the timeout status, a reset of the adapter could occur. There is also a problem with reset recovery that would cause the protocol to stop responding.

RESOLUTION

To resolve this problem, obtain the latest service pack for Windows NT 4.0 or Windows NT Server 4.0, Terminal Server Edition. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

152734 How to Obtain the Latest Windows NT 4.0 Service Pack


STATUS

Microsoft has confirmed that this is a problem in Windows NT 4.0 and Windows NT Server 4.0, Terminal Server Edition. This problem was first corrected in Windows NT 4.0 Service Pack 4.0 and Windows NT Server 4.0, Terminal Server Edition Service Pack 4.

Modification Type:MinorLast Reviewed:9/23/2005
Keywords:kbHotfixServer kbQFE kbbug kbfix kbQFE KB186150