Error Message: Cannot Find the File <Folder>... (186149)



The information in this article applies to:

  • Microsoft Internet Explorer 1.0 for Windows 95
  • Microsoft Internet Explorer 2.0 for Windows 95
  • Microsoft Internet Explorer 3.0 for Windows 95
  • Microsoft Internet Explorer 3.01 for Windows 95
  • Microsoft Internet Explorer 3.02 for Windows 95
  • Microsoft Internet Explorer 4.0 for Windows 95
  • Microsoft Internet Explorer 4.01 for Windows 95
  • Microsoft Internet Explorer 5.0 for Windows 95
  • Microsoft Internet Explorer 5.01 for Windows 95
  • Microsoft Internet Explorer 5.5 for Windows 95
  • Microsoft Internet Explorer 3.x for Windows 95
  • Microsoft Internet Explorer 4.x for Windows 95

This article was previously published under Q186149

SYMPTOMS

If you are using Program Manager (Progman.exe) as your Windows shell, and you attempt to use the Run command on the File menu to access a folder on your local hard disk or on a shared network drive, you may receive the following error message when you click OK in the Run dialog box
Cannot find the file <folder> (or one of its components). Check to ensure the path and filename are correct and that all required libraries are available.
where <folder> is <drive letter>:\<folder> if the folder is on your local hard disk, or \\<computer name>\<folder> if the folder is on a shared network drive.

When you click OK, the folder you are trying to access is opened.

CAUSE

This problem can occur if Internet Explorer 4.0 or 4.01 is installed with the Windows Desktop Update component.

RESOLUTION

To work around this problem, use either of the following methods:

Method 1

Change the Windows shell to Explorer (Explorer.exe). To do so, follow these steps:
  1. On the File menu, and click Run.
  2. In the Command Line box, type system.ini, and then OK.
  3. Disable the following line in the [Boot] section of the System.ini file by placing a semicolon (;) at the beginning of the line:
    shell=progman.ini
    						
  4. Type the following line beneath the line you disabled in step 3:
    shell=explorer.exe
    						
  5. On the File menu, click Save, and then click Exit on the File menu.
  6. Restart your computer.

Method 2

Remove the Windows Desktop Update component. For information about how to do so, please see the following article in Microsoft Knowledge Base:

165695 How to Add or Remove Windows Desktop Update

STATUS

Microsoft has confirmed this to be a problem in Microsoft Internet Explorer versions 4.0 and 4.01.

Modification Type:MajorLast Reviewed:12/17/2003
Keywords:kberrmsg kbprb KB186149