PRB: GetAddressByName() Returns ERROR_FILE_NOT_FOUND (185725)
The information in this article applies to:
- Microsoft Windows 95
- Microsoft Windows 95 OEM Service Release
This article was previously published under Q185725 SYMPTOMS
The Winsock API GetAddressByName() fails with error 2
(ERROR_FILE_NOT_FOUND) when trying to obtain information on a particular
service.
CAUSE
This only occurs on computers with fresh installs of Windows 95 that have
never had either the Microsoft TCP/IP protocol or the Microsoft Client for
Netware Networks installed.
RESOLUTION
To alleviate this problem, create a registry key named ExcludedProviders
under:
HKEY_LOCAL_MACHINE\System\CurrentControlSet\control\
ServiceProvider\Order\
Once you have created this key, there will be the following default string
pair:
(Default)=(value not set)
Click on (Default), and then right-click to choose modify. A dialog box
where you can change the value data appears. Make sure that the value data
field is totally empty, and then click OK. The new value pair will look as
follows:
STATUS
Microsoft is researching this problem and will post new information here in
the Microsoft Knowledge Base as it becomes available.
Modification Type: | Major | Last Reviewed: | 10/29/2003 |
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Keywords: | kbAPI kbnetwork kbpending kbprb kbWinsock KB185725 |
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