OL98: Data Missing When Importing and Exporting (185418)



The information in this article applies to:

  • Microsoft Outlook 98

This article was previously published under Q185418

SYMPTOMS

After importing to or exporting from a foreign file format into Microsoft Outlook 98, you may find that some items are missing. Initial attempts to perform this operation may be successful, but the results may be inconsistent on later attempts.

CAUSE

This condition exists because the binary mapping file for the file type contains incomplete information about the fields to be imported and exported.

RESOLUTION

Remove the current mapping file for the data type and method for which you are trying to import or export. Export a sample file in order to create a new mapping file containing all the necessary fields to allow a complete import to Outlook.

Mapping files for the various Outlook items are located in the Windows folder. A list of the mapping file extensions for each Outlook item follows:

  • Contacts .adr
  • Mail .eml
  • Journal .jnl
  • Tasks .tsk
  • Appointments .cal
  • Notes .not
As an example, data that is being imported using Microsoft Excel will use a newly created file called Microsoft Excel. <*>, where the asterisk indicates the extension for the Outlook item listed above.

MORE INFORMATION

Outlook creates the mapping file for each file type on the first import or export attempt. The fields defined at this time are stored in the mapping file. Outlook uses this file as a filter for each subsequent operation.

For example, assume you have a Microsoft Excel file that contains only the fields, First Name, Middle Name, and Last Name. If you import this information into Outlook Contacts, the resulting .adr file maps only this information. Subsequent Excel file imports containing additional fields such as, Business Address, Categories, and Fax Numbers, may not filter properly through the .adr file, resulting in missing data.

The same situation applies to Comma Separated (csv) and Tab Delimited (tsv) text files. Outlook creates a separate .adr file for each file type at the time of the first import or export.

How to Optimize Outlook Field Mapping

These steps use Outlook Contacts and the .adr as the example. To create mapping files that will successfully map all imported fields into Outlook, follow these steps:
  1. Quit Outlook. On the Start menu point to Find and then Files or Folders.
  2. In the Named box type "*.adr" (without the quotation marks) to locate all current .adr files and then click Find Now. Delete all .adr files if any are found.
  3. Start Outlook. In the Folder List, click the folder from which you want to import and export. For example, if you are working with contacts, click to select the Contacts folder.
  4. On the File menu, point to Folder and then click New Folder. In Create New Folder, type the name Test for this new folder. Ensure that the folder you selected in step 3 is also selected under "Select where to place the folder" and that Contact items is selected in Folder Contains. Click OK. You should see a subfolder with the name "Test" indented to the right of your Contacts folder.
  5. On the File menu, click Import And Export and then in "Choose an action to perform" click "Export to a File." Click Next.
  6. In "Create a file of type", click Microsoft Excel and then click Next.
  7. In "Select a folder to Export from", click the folder, "Test" if it is not all ready selected. Click Next.
  8. Click Browse to select a location to save the exported file and type Test in the File Name box. The path will appear in "Save Exported File As." Click OK and then Next. Click Finish to export the file.
The exported file will contain a single row, called a header row, which defines the 87 internal fields that Outlook uses for Contacts. You can use this Excel file as a template each time you wish to import data to Outlook. The newly created file, Microsoft Excel.adr, will contain information about all Contacts fields and will handle Excel data even though all fields are not used in the source file. Adding additional fields that are not recognized in the group of internal fields may cause subsequent import and export failures as described above.

Again, for clarity, the Outlook Contacts folder is used in the examples above. The same method would be used when importing information from the other Outlook folders. The method applies for other file types as mentioned above; a separate mapping file will be created for each file type.

REFERENCES

For more information on field mapping in Outlook, please see the following article(s) in the Microsoft Knowledge Base:

180315 OL98: Importing from Microsoft Excel Requires Named Range

182728 OL98: Field Mapping for Importing Not Available

For more information on Outlook internal fields, please see the following article in the Microsoft Knowledge Base:

185361 OL98: Internal Fields Used by Outlook Folders


Modification Type:MajorLast Reviewed:7/24/1999
Keywords:kbprb KB185418