SMS: Service Pack Upgrades Not Automatic for RAS Clients (185344)
The information in this article applies to:
- Microsoft Systems Management Server 1.2
This article was previously published under Q185344 SYMPTOMS
Windows 95 clients that dial in to the network by means of RAS will not
upgrade to a later Systems Management Server service pack or receive other
Systems Management Server file updates.
CAUSE
When a user logs on through RAS, Smsrun16.exe does not connect to a logon
server during the logon process. This is because SMSRUN16 typically runs
from the load line of the client's Win.ini file, which starts well before a
RAS session is established.
When the client uses RAS to dial in and calls the Runsms.bat or Smsls.bat
batch files from its logon script, RUNSMS and SMSLS alter the Sms.ini file
to put the client in "Upgrade Mode." However, by the time this occurs,
SMSRUN16 has finished processing. Therefore, the client will not connect to
a logon server to perform the upgrade.
WORKAROUND
To work around this problem, call Smsrun16.exe in the client's logon script
after the logon process is complete. This restarts Smsrun16.exe, which will
then parse the Sms.ini, see the UPGRADE flag, and perform the upgrade.
| Modification Type: | Minor | Last Reviewed: | 6/14/2005 |
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| Keywords: | kbConfig kbprb kbsetup kbsmsUtil KB185344 |
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