Windows NT Remote Boot Clients Lose Enhanced Keyboard Support (183464)
The information in this article applies to:
- Microsoft Windows NT Workstation 4.0
- Microsoft Windows NT Server 4.0
This article was previously published under Q183464 SYMPTOMS
Following a remote program load (RPL) boot from a Windows NT server,
enhanced keyboard functionality is lost on the client for some
applications.
CAUSE
The Rpldisk.sys driver, used during the initial phase of a remote boot,
mistakenly clears a bit in the BIOS area in the memory of the client system
that indicates whether the attached keyboard is an enhanced keyboard.
Applications that check this flag to determine how to interact with the
keyboard will fail to detect an enhanced keyboard, and may elect not to use
enhanced keyboard functions.
RESOLUTION
To resolve this problem, obtain the following fix.
This fix should have the following time stamp:
04/02/98 10:14a 26,761 Rpldisk.sys (Intel)
STATUS
Microsoft has confirmed this to be a problem in Windows NT version 4.0. A
supported fix is now available, but has not been fully regression tested
and should be applied only to systems experiencing this specific problem.
Unless you are severely impacted by this specific problem, Microsoft
recommends that you wait for the next service pack that contains this fix.
Contact Microsoft Technical Support for more information.
Modification Type: | Minor | Last Reviewed: | 9/23/2005 |
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Keywords: | kbHotfixServer kbQFE kbbug kbfix kbQFE KB183464 |
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