BUG: InfoViewer Fails to Print Multiple Topics or Large Books (183435)



The information in this article applies to:

  • Microsoft Internet Explorer 4.01 for Windows NT 4.0
  • Microsoft Internet Explorer 4.0 for Windows NT 4.0
  • Microsoft Internet Explorer 4.01 for Windows 95
  • Microsoft Internet Explorer 4.0 for Windows 95
  • Microsoft Developer Network Subscriptions

This article was previously published under Q183435

SYMPTOMS

When using Internet Explorer 4.0 or 4.01, InfoViewer 5.0 fails to print multiple topics in large books. The following error message appears:
Internet Explorer can not open the Internet site
file:<//C:\temp\055cadf5.htm.>
Invalid argument.
Followed by a second error message that states:
Internet Explorer can not open the Internet site
file:<//C:\temp\055cadf5.htm.>
The system can not find the file specified.
NOTE: A random filename is generated where <//C:\temp\055cadf5.htm> appears in the error messages.

CAUSE

InfoViewer prints multiple topics by concatenating them together and massaging the paths as required to ensure that links are correct. Once the files are concatenated, the resulting file is loaded into a hosted WebBrowser control. At that point, the file is in Internet Explorer's memory and temporary file is also saved. A print command is sent to the WebBrowser control, which is provided by Internet Explorer, that asks it to print the merged topics. If the merged topic is too large, Internet Explorer 4.0 or 4.01 attempts to access the temporary file from disk. However, the temporary file is deleted before it can be printed. Previous versions of Internet Explorer do not delete this file before InfoViewer has a chance to print it.

RESOLUTION

To work around this problem, choose one of the following options:
  • Print in smaller books or individual topics.

  • Install Internet Explorer 3.02.

STATUS

Microsoft has confirmed this to be a bug in the Microsoft products listed at the beginning of this article. We are researching this bug and will post new information here in the Microsoft Knowledge Base as it becomes available.

Modification Type:MajorLast Reviewed:12/16/2003
Keywords:kbBug kbpending KB183435