XCON: X400 Address Replaces SMTP Address When Resending Message (183270)
The information in this article applies to:
- Microsoft Exchange Server 5.0
- Microsoft Exchange Server 5.5
This article was previously published under Q183270 SYMPTOMS
When a message is sent to a Simple Mail Transfer Protocol (SMTP) recipient
and is then sent back to the message originator non-delivered, an X.400
address of the message recipient may be displayed when attempting to resend
the message.
An example would be when sending a message to user@domain.com from the
Exchange client. The message goes to the Internet Mail Service connector
and then is sent back because the domain, domain.com, was not found. When
attempting to resend the message, the TO line will contain the following:
c=us;a= ;p=Microsoft;o=Site;dda:SMTP=user@domain.com
The message can be sent again, however, and will only be sent back if the
same condition that prevented its original delivery persists.
CAUSE
This problem will occur when a message originates on an Exchange Server
computer (XS1) that has an X.400 Connector or Site Connector to another
Exchange Server computer (XS2) where the actual Internet Mail Service
connector resides.
The message leaves XS1 and goes to XS2 to be placed in the outbound queue
for the Internet Mail Service. As the message traverses the X.400 Connector
or Site Connector, it is encapsulated in an X.400 address in order to be
handled by the Exchange Server message transfer agent (MTA). After the
message reaches the Internet Mail Service on XS2, the X.400 address is
stripped down to just the basic SMTP address of user@domain.com.
When the message is undeliverable by the Internet Mail Service, it sends
the message back to the originator (on XS2) by re-encapsulating the message
to an X.400 address for both the originator and the recipient. The result
is the X.400 address appears in the TO field when the client attempts to
resend the message.
WORKAROUND
This problem is mostly cosmetic in nature. When the client sends a message
to user@domain.com, after it leaves the Outbox, Exchange Server immediately
encapsulates the raw SMTP address to the X.400 address.
When the client goes to resend the message with the encapsulated X.400
address, the message will still be sent back to the Internet Mail Service
for processing because the X.400 address shows the proper route back to the
Internet Mail Service.
STATUS
Microsoft has confirmed this to be a problem in Exchange Server 5.0
and 5.5.
Modification Type: | Minor | Last Reviewed: | 4/28/2005 |
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Keywords: | kbprb KB183270 |
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