FP98: Navigation Bars Don't Show up on Search Results Page (183034)
The information in this article applies to:
- Microsoft FrontPage 98 for Windows
This article was previously published under Q183034 SYMPTOMS
When you submit a search on a page containing the FrontPage Search component, the results are
returned, but the navigation bars on the page are gone.
CAUSE
This behavior occurs when the server hosting your web is running Microsoft Index Server. When
you save a page that contains a Search Form component, FrontPage creates an .idq file. This
file is used by Index server to determine which folders and files to search. FrontPage also
creates a template file to be used for the results. This file is stored in the _derived folder
and is named <filename>.htm0.htx where <filename> is the name of the file that
contains the Search Form component. Because this template file is not in the navigation
structure of the web, the navigation bars don't appear in the Web browser.
RESOLUTION
To work around this behavior, use one of the following methods:
Method 1: Use a Standard Form and a Custom .idq File
Use a standard form and create a custom .idq file to be used with Index Server. For additional
information, please see the following article in the
Microsoft Knowledge Base:
166357 FP: How to Use FrontPage with Microsoft Index Server
Method 2: Use the FreeWAIS Search Engine
Use the FreeWAIS search engine included with the FrontPage Server Extensions.
For additional information, please see the following article in the Microsoft Knowledge Base:
181204 FP: Using FrontPage Search Engine Instead of MS Index Server
STATUS
Microsoft has confirmed this to be a problem in the Microsoft products listed at the beginning of this article.
Modification Type: | Major | Last Reviewed: | 12/1/2000 |
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Keywords: | kbbug KB183034 |
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