OL98: (CW) Error Using Duplicate Internet Mail Account Names (181989)



The information in this article applies to:

  • Microsoft Outlook 98

This article was previously published under Q181989
IMPORTANT: This article contains information about editing the registry. Before you edit the registry, make sure you understand how to restore it if a problem occurs. For information about how to do this, view the "Restoring the Registry" Help topic in Regedit.exe or the "Restoring a Registry Key" Help topic in Regedt32.exe.

NOTE: These procedures only apply if you have installed Outlook with the Corporate Workgroup/Other option. This option allows you to use Messaging Application Programming Interface (MAPI) services. To determine your installation type, on the Help Menu click About Microsoft Outlook. In About Microsoft Outlook you should see "Corporate" if you have the Corporate Workgroup installation.

SYMPTOMS

When you attempt to configure an Internet mail account in Microsoft Outlook, you may receive the following error message:
An account already exists with this name. Please enter a unique account name.

CAUSE

You have used the same "friendly name" to describe the new account as you previously used for another account.

RESOLUTION

The registry retains the old profile name even though the profile no longer exsists. Find and delete the corresponding registry key.

Always use a unique friendly mail account name when setting up a new Internet E-mail account on the same computer.

MORE INFORMATION

The Internet E-mail service allows you to define multiple Internet Mail accounts in the same user profile. You cannot however, use duplicate friendly mail account names on the same computer, even if they are in different user profiles.

WARNING: Using Registry Editor incorrectly can cause serious problems that may require you to reinstall Windows 95. Microsoft cannot guarantee that problems resulting from the incorrect use of Registry Editor can be solved. Use Registry Editor at your own risk.

For information about how to edit the registry, view the Changing Keys And Values online Help topic in Registry Editor (Regedit.exe). Note that you should make a backup copy of the registry files (System.dat and User.dat) before you edit the registry.
  1. Quit all programs.
  2. On the Windows taskbar, click Start and then click Run.
  3. In the Open box, type regedit and then click OK.
  4. In the left window of the Registry Editor navigate to and click to select the following key:

    HKEY_CURRENT_USER\Software\Microsoft\Office\8.0\Outlook\Internet Account Manager\Accounts\(Account name)

    where Account name is the name of the previously existing profile.
  5. Delete the key corresponding to the profile.
  6. On the Registry menu, click Exit to close the Registry Editor.
  7. Reconfigure the profile with the desired name.
NOTE: In some cases, it may also be necessary to delete the OMI Account Manager key, located at

HKEY_CURRENT_USER\Software\Microsoft\Office\8.0\Outlook\OMI Account Manager


Modification Type:MajorLast Reviewed:7/31/1999
Keywords:kbprb KB181989