OL98: (CW) Importing a PDL from a PAB May Cause Duplicate Contacts (181695)



The information in this article applies to:

  • Microsoft Outlook 98

This article was previously published under Q181695
NOTE: These procedures only apply if you have installed Outlook with the Corporate Workgroup/Other option. This option allows you to use Messaging Application Programming Interface (MAPI) services. To determine your installation type, on the Help Menu click About Microsoft Outlook. In About Microsoft Outlook you should see "Corporate" if you have the Corporate Workgroup installation.

SYMPTOMS

In Microsoft Outlook 98, importing a Personal Address Book (PAB) that contains a Personal Distribution List (PDL) may generate duplicate Contact records.

CAUSE

The import process sets up a Contact record for each entry in a PDL. If the PDL entries are also in the PAB, then Contacts are set up for these records also, resulting in duplicates.

RESOLUTION

Delete the duplicate Contacts after importing your PAB, or include only entries not found in your PAB list in the PDL. If the PDL entries are located in other than the PAB, such as another Contact list or a Global Address Book, no duplicates will occur.

MORE INFORMATION

Steps to Reproduce Problem

  1. Build a Personal Distribution List in your Personal Address Book. Add entries from the Personal Address Book and others from another source such as a Global Address List, a Contact list, and such.
  2. Import the Personal Address List into an empty Contact folder.
RESULTS: The import process duplicates those PDL entries coming from the PAB in the new Contact folder. Those coming from another source are not duplicated.

Modification Type:MajorLast Reviewed:7/27/1999
Keywords:kbprb KB181695