Error -1201 occurs when you try to start the Information Store (181559)
The information in this article applies to:
- Microsoft Exchange Server 4.0
- Microsoft Exchange Server 5.0
- Microsoft Exchange Server 5.5
This article was previously published under Q181559 SYMPTOMS
When you try to start the Microsoft Exchange Server Information Store
service, the service does not start and reports a server-specific error
4294966095. The Windows NT Event Viewer indicates that the service returned
an error -1201.
CAUSE
Error -1201 commonly occurs because of minor inconsistencies or corruption in
the Priv.edb or Pub.edb files.
It can also occur when the *.edb files are on drive C, the *.log files are
on drive D, and there is some sort of unrecoverable hardware failure on
drive D. At that point, you are in the situation described above because
the store will be inconsistent and the log files are not available.
WORKAROUND
The recommended approach to resolving this problem is to restore the
information store from the latest backup.
If a recent backup is not available, or if restoring the backup will result
in data loss (circular logging is enabled) follow these steps:
- Back up the entire Mdbdata folder.
- Make sure you have sufficient free disk space:
Exchange Server 4.0 and 5.0
You need 110 percent of the larger of Priv.edb and Pub.edb
files in free disk space.
Exchange Server 5.5
You need 25 percent of the larger of Priv.edb and Pub.edb
files in free disk space. - Run the following commands from a Windows NT command prompt:
Exchange Server 4.0 and 5.0
edbutil /d /r /ispriv /tx:\tempdfg.edb
edbutil /d /r /ispub /tx:\tempdfg.edb edbutil /d /ispriv /tx:\tempdfg.edb edbutil /d /ispub /tx:\tempdfg.edb
isinteg -fix -pri
isinteg -fix -pubExchange Server 5.5
eseutil /p /ispriv /tx:\tempdfg.edb
eseutil /p /ispub /tx:\tempdfg.edb eseutil /d /ispriv /tx:\tempdfg.edb eseutil /d /ispub /tx:\tempdfg.edb
isinteg -fix -pri -test alltests
isinteg -fix -pub -test alltests
where x: is the drive containing the required free disk
space.
NOTE:
When the Information Store service has started, after the
repair process, make a full online backup immediately.
MORE INFORMATION
Error -1201 refers to the Jet error: JET_errDatabaseDuplicate
The Windows NT Event Viewer Application log may also report Event ID 9037
generated by the information store.
Modification Type: | Minor | Last Reviewed: | 4/21/2005 |
---|
Keywords: | kbprb KB181559 |
---|
|