OFF98: Web Help Menu Items and Hyperlinks Do Not Work (181508)
The information in this article applies to:
- Microsoft Excel 98 Macintosh Edition
- Microsoft Word 98 Macintosh Edition
- Microsoft PowerPoint 98 Macintosh Edition
- Microsoft Office 98 Macintosh Edition
This article was previously published under Q181508 SYMPTOMS
In Microsoft Office 98 Macintosh Edition, the following problems may occur:
- When you click Help On The Web or Online Registration on the Help
menu, nothing happens.
- When you click a hyperlink in a worksheet, you receive the following
error message:
Opening <filename>
Some files can contain viruses or otherwise be harmful to your
computer. It is important to be certain that this file is from a
trustworthy source.
Would you like to open this file?
If you click OK, you receive the following error message in the
Finder:
Could not find the application program that created the document
named "<filename>".
and you are asked to choose a program to use to open the document.
- When you click a hyperlink in a worksheet, the document to which
you are linking is opened in SimpleText.
- You receive the following error message when you click a hyperlink or
open a Web page:
Office cannot open the URL you specified. Make sure you have a web
browser installed and that it is configured correctly.
CAUSE
These problems may occur if either of the following preference files, both
located in the "System Folder:Preferences" folder, contain invalid or
missing settings:
Internet Preferences
Mac OS Easy Open Preferences
WORKAROUND
To correct these problems, rebuild the preferences files by performing the
following steps that are appropriate for your Web browser.
If You Are Running Microsoft Internet Explorer- Start the Internet Config program, which is located in the following
folder:
Internet:Internet Utilities:Internet Config - Click File Mappings. Click Add in the File Mappings dialog box.
- Type "HTML Document", without quotation marks, in the Name box.
- Type ".htm", without quotation marks, in the Extension box.
- Type "text/html", without quotation marks, in the MIME Type box.
- Type "TEXT", without quotation marks, in the File Type box.
- Type "MSIE", without quotation marks, in the File Creator box.
- Click OK to dismiss the Mapping Entry dialog box. Close the File
Mappings dialog box.
- Click Save on the File menu. Click Quit to quit Internet Config.
The next time that you start a Microsoft Office program, the problems
described at the beginning of this article will no longer occur.
If You Are Running Netscape Navigator
Note also that some Internet-related settings may be lost when you perform
these steps. You may need to write down your Internet-related settings
before you proceed.
- Quit all running programs.
- Using the Finder, go to the "System Folder:Preferences" folder. Drag
the following files into the trash:
Internet Preferences
Mac OS Easy Open Preferences
On the Special menu, click Empty Trash. Click OK to empty the trash.
- Start the Internet Config program, which is located in the following
folder:
Internet:Internet Utilities:Internet Config
Click File Mappings. Click Defaults, and then click Revert. Close the
File Mappings window, and then click Quit on the File menu. Click Save.
- On the Apple menu, point to Control Panels, and click Configuration
Manager. In the list on the left side of the dialog box, under
Network, select Protocol Helpers.
Repeat step 5 for each of the following items in the Protocol list:
file
gopher
ftp
http
https - Select the item in the Protocol list. Click Change. Click Choose
Helper. Using the dialog box, go to the folder that contains Netscape
Navigator (usually, Internet:Internet Applications:Navigator). Select
Netscape Navigator, and then click Open. Click OK.
- In the list on the left side of the dialog box, under Receiving
Files, select File Helpers.
- In the File Helper Settings list, select the HyperText item whose
Extension (shown on the right) is ".htm". Click Change. In the
Handling section, select View With Browser in the "How to handle" list.
Click OK.
- On the File menu, click Quit. Click Save to save the changes to the
configuration.
- Start Microsoft Excel.
- Click Hyperlink on the Insert menu. Click Don't Save.
- Click Select under "Link to file or URL:". Go to the "Microsoft Office
98:Office:Help" folder, and then select Webhelp.htm. Click OK to
dismiss the Link to File dialog box. Click OK to close the Insert
Hyperlink dialog box.
- Click the hyperlink. Click OK when asked if you would like to open the
file.
- Click Finder on the Application menu in the upper-right corner of your
screen. Click Netscape Navigator in the list of programs, and then
click Open.
Netscape Navigator will start and open the file Webhelp.htm.
- Click Quit on the File menu to quit Netscape Navigator.
- Click Quit on the File menu to quit Microsoft Excel. Click Don't Save
when prompted to save the changes that you made.
The next time that you start a Microsoft Office program, the problems
described at the beginning of this article will no longer occur.
STATUS
Microsoft has confirmed this to be a problem in the Microsoft products
listed at the beginning of this article. We are researching this problem
and will post new information here in the Microsoft Knowledge Base as it
becomes available.
MORE INFORMATION
The problems described above occur because the programs included in
Microsoft Office 98 Macintosh Edition may assume that you have Microsoft
Internet Explorer installed on your computer, especially when preferences
files are initially created. Depending on the order in which you install
your programs, the problems may occur.
Netscape Navigator is manufactured by Netscape, a vendor independent of
Microsoft; we make no warranty, implied or otherwise, regarding this
product's performance or reliability.
Modification Type: | Major | Last Reviewed: | 11/25/2003 |
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Keywords: | kbbug kbpending kbusage KB181508 |
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