FP98: HTTP Error 404 Submitting Form w/Save Results Form Handler (181205)



The information in this article applies to:

  • Microsoft FrontPage 98 for Windows

This article was previously published under Q181205

SYMPTOMS

When you click the Submit button on a form, the following error message appears in the Web browser:
404 Not Found. The requested URL /nortbots/_derived/nortbots.htm was not found on this server.
NOTE: The error may be different depending on which type of server your Web resides.

CAUSE

When you set up a form on a disk-based web to send results to a file or e-mail address, FrontPage configures the form so that the Nortbots.htm page will be displayed in the Web browser. When you submit the form from the disk-based web, the following information appears in the Web browser:

FrontPage Run-Time Component Page. You have submitted a form or followed a link to a page that requires a Web server and the FrontPage Server Extensions to function properly.

This form or other FrontPage components will work correctly if you publish this Web to a Web server that has the FrontPage Server Extensions installed.

Click the <Back> arrow to return to the previous page.

When you publish the Web to a Web server, FrontPage does not publish Nortbots.htm. FrontPage also does not configure the form to work with the FrontPage Server Extensions.

NOTE: This behavior also occurs if you are using the Discussion Form Handler or the Registration Form Handler.

RESOLUTION

To work around this behavior use one of the following methods.

Method 1: Upgrade the FrontPage Server Extensions on the Server

For information about obtaining and installing the FrontPage Server Extensions, please see the following Microsoft web site:

NOTE: You may need to recalculate hyperlinks after you install the new version of the server extensions.

Method 2: Remove the Reference to Nortbots.htm

  1. In FrontPage Explorer, open your Web on the server.
  2. Double-click the page that contains the form. The page will open in FrontPage Editor.
  3. Click inside the form area. NOTE: The dashed line indicates the boundary of the form.
  4. Click the HTML tab at the bottom of the FrontPage Editor window. You will see HTML code similar to the following:
       <form method="POST" name="myform"
       onSubmit="location.href='_derived/nortbots.htm';return false;"
       action="--WEBBOT-SELF--">
    						
  5. Remove the entire line of code that begins with the "onSubmit" statement. Your code will now look similar to the following:
       <form method="POST" name="myform"
       action="--WEBBOT-SELF--">
    						
  6. On the File menu, click Save.

Method 3: Re-create the Form

  1. In FrontPage Explorer, open your Web on the server.
  2. Double-click the page that contains the form. The page will open in FrontPage Editor.
  3. Select a form field and then press DELETE. Repeat this step until you have deleted all form fields.
  4. Press DELETE to delete the form (indicated by the dashed line boundary).
  5. On the Insert menu, point to Form Field, and click the form field option you want to add to your form. Repeat this step until you have recreated your form.
  6. On the File menu, click Save.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.

MORE INFORMATION

For additional information, please see the following article in the Microsoft Knowledge Base:

173437 FP98: Some FrontPage Components Do Not Work on Disk-Based Webs


Modification Type:MajorLast Reviewed:12/1/2000
Keywords:kbbug KB181205