Save This Program To Disk Option Missing During File Download (181145)



The information in this article applies to:

  • Microsoft Internet Explorer 5.0 for Windows NT 4.0
  • Microsoft Internet Explorer 4.01 for Windows NT 4.0 SP 1
  • Microsoft Internet Explorer 4.01 for Windows NT 4.0 SP 2
  • Microsoft Internet Explorer 4.0 for Windows NT 4.0
  • Microsoft Internet Explorer 5.0 for Windows 98
  • Microsoft Internet Explorer 4.01 for Windows 98 SP 2
  • Microsoft Internet Explorer 5.0 for Windows 95
  • Microsoft Internet Explorer 4.01 for Windows 95 SP 1
  • Microsoft Internet Explorer 4.01 for Windows 95 SP 2
  • Microsoft Internet Explorer 4.0 for Windows 95
  • the operating system: Microsoft Windows 98 Second Edition

This article was previously published under Q181145

SYMPTOMS

When you try to download more than two files at the same time, the "Save This Program To Disk" option may not appear until one or more of the previous downloads is finished.

CAUSE

This behavior can occur because Internet Explorer versions 4 and 5 strictly adhere to the Request for Comment (RFC) specifications for HTTP 1.0 and HTTP 1.1, which state that clients must not create more than two (HTTP 1.1) or four (HTTP 1.0) simultaneous keep-alive connections per server.

RESOLUTION

To work around this issue, do not try to download more than four files at the same time.

For additional information about this issue, please see the following article in the Microsoft Knowledge Base:

183110 INFO: WinInet Limits Connections Per Server


Modification Type:MajorLast Reviewed:12/5/2003
Keywords:kbenv kbprb KB181145