Computer Hangs When Installing Additional Components (180968)



The information in this article applies to:

  • Microsoft Internet Explorer 1.0 for Windows 95
  • Microsoft Internet Explorer 2.0 for Windows 95
  • Microsoft Internet Explorer 3.0 for Windows 95
  • Microsoft Internet Explorer 3.01 for Windows 95
  • Microsoft Internet Explorer 3.02 for Windows 95
  • Microsoft Internet Explorer 4.0 for Windows 95
  • Microsoft Internet Explorer 4.01 for Windows 95
  • Microsoft Internet Explorer 5.0 for Windows 95
  • Microsoft Internet Explorer 5.01 for Windows 95
  • Microsoft Internet Explorer 5.5 for Windows 95
  • Microsoft Internet Explorer 3.x for Windows 95
  • Microsoft Internet Explorer 4.x for Windows 95
  • Microsoft Internet Explorer 2.0 for Windows NT 4.0
  • Microsoft Internet Explorer 3.0 for Windows NT 4.0
  • Microsoft Internet Explorer 3.01 for Windows NT 4.0
  • Microsoft Internet Explorer 3.02 for Windows NT 4.0
  • Microsoft Internet Explorer 4.0 for Windows NT 4.0
  • Microsoft Internet Explorer 4.01 for Windows NT 4.0
  • Microsoft Internet Explorer 5.0 for Windows NT 4.0
  • Microsoft Internet Explorer 5.01 for Windows NT 4.0
  • Microsoft Internet Explorer 5.5 for Windows NT 4.0

This article was previously published under Q180968

SYMPTOMS

When you attempt to install additional components from the Internet Explorer 4.0 Component Download Web page, your computer may stop responding (hang) after you receive the following message:

Internet Explorer 4.01 SP1 setup is initializing

CAUSE

This behavior can occur if a registry key is damaged or contains an incorrect value.

RESOLUTION

To resolve this issue, use either of the following methods:

Method 1

  1. Click Start, and then click Run.
  2. In the Open box, type regsvr32 asctrls.ocx, and then click OK.
  3. Click Start, and then click Run.
  4. In the Open box, type regsvr32 inseng.dll, and then click OK.

Method 2

  1. Restart Windows 95, press the F8 key when you see the "Starting Windows 95" message, and then choose Safe Mode Command Prompt Only from the Startup menu.
  2. At the command prompt, type the following lines, pressing ENTER after each line:
          cd \windows\system
          ren asctrls.ocx asctrls.old
          ren inseng.dll inseng.old
          ren advpack.dll advpack.old
          ren w95inf16.dll w95inf16.old
          ren w95inf32.dll w95inf32.old
    						
  3. Restart your computer normally.
  4. Uninstall and then reinstall Internet Explorer.

    For information about uninstalling Internet Explorer, please see the following article in the Microsoft Knowledge Base:

    174265 How to Uninstall Internet Explorer 4.0


Modification Type:MajorLast Reviewed:12/16/2003
Keywords:kbprb kbsetup KB180968