Err Msg: Error Writing to LPT1: Access Denied (180892)
The information in this article applies to:
- Microsoft Windows 2000 Server
- Microsoft Windows 2000 Advanced Server
- Microsoft Windows 2000 Professional
- Microsoft Windows 2000 Datacenter Server
- Microsoft Windows NT Server 4.0
- Microsoft Windows NT Workstation 4.0
- Microsoft Windows NT Server, Enterprise Edition 4.0
This article was previously published under Q180892 IMPORTANT: This article contains information about modifying the registry. Before you
modify the registry, make sure to back it up and make sure that you understand how to restore
the registry if a problem occurs. For information about how to back up, restore, and edit the
registry, click the following article number to view the article in the Microsoft Knowledge Base:
256986 Description of the Microsoft Windows Registry
SYMPTOMS
When you attempt to print to a Hewlett-Packard (HP) 4000-series printer
connected to printer port LPT1, you may receive one of the following error
messages:
Or, the print job may become stuck in the spooler.
CAUSE
This behavior can occur when you install the HP 4000-series printer
drivers included with the HP Complete Printing System for Windows
from Hewlett-Packard.
NOTE: This behavior can occur when you try to print to printers other than
HP4000-series printers if HP Complete Printing System for Windows
is installed on the computer.
RESOLUTIONWARNING: If you use Registry Editor incorrectly, you may cause serious problems that may
require you to reinstall your operating system. Microsoft cannot guarantee that you can solve
problems that result from using Registry Editor incorrectly. Use Registry Editor at your own
risk.
To resolve this issue, rename the Hpdcmon.dll file in the
%SystemRoot%\System32 folder. To do so, type the following line at
a command prompt:
ren c:\%SystemRoot%\System32\Hpdcmon.dll Hpdcmon.xxx
If this does not resolve the problem, follow these steps:
- Start Registry Editor (Regedt32.exe).
- Go to the following key:
HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\Print\Monitors\HP Laserjet 5 Language Monit NOTE: The HP Language Monitor key may vary in name depending on which
HP driver is installed.
NOTE: Do not delete the PJL Language Monitor key.
- On the Edit menu, click Delete, and then quit Registry Editor.
- Click Start, point to Settings, and then click Control Panel.
- Double-click Add/Remove Programs, and then click the Install/Uninstall
tab. If HP Printing System appears in the list of installed programs,
click Add/Remove.
- Click OK, and then restart your computer.
- After your computer restarts, install your printer drivers.
NOTE: If you install the HP-provided drivers, use the minimal
installation option.
MORE INFORMATION
The third-party product discussed in this article is manufactured by
a vendor independent of Microsoft; we make no warranty, implied or
otherwise, regarding this product's performance or reliability.
Modification Type: | Major | Last Reviewed: | 5/20/2003 |
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Keywords: | kberrmsg kbprb kbprint KB180892 |
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