Print Server may experience occasional performance degradation (180863)
The information in this article applies to:
- Microsoft SNA Server 3.0
- Microsoft SNA Server 3.0 SP1
- Microsoft SNA Server 3.0 SP2
- Microsoft SNA Server 4.0
This article was previously published under Q180863 IMPORTANT: This article contains information about editing the registry.
Before you edit the registry, make sure you understand how to restore it if
a problem occurs. For information about how to do this, view the "Restoring
the Registry" Help topic in Regedit.exe or the "Restoring a
Registry Key" Help topic in Regedt32.exe.
SYMPTOMS
When a print job is sent to a printer attached to a workstation that has
been unplugged from the network or has encountered a blue screen STOP
screen, all SNA Server printer sessions start printing very slowly (for
example, five minutes per page) until the workstation has recovered.
CAUSE
SNA Server Print Server is not optimizing the use of threads for the number
of print sessions that are running.
WORKAROUND
If the print job that caused the problem (that is, the print job on the
workstation that had previously encountered a blue screen STOP message) is
deleted on the host side, printing for the other print sessions will resume
normally.
STATUS
Microsoft has confirmed this to be a problem in SNA Server versions 3.0,
3.0 SP1, and 4.0.
This problem was corrected in the latest SNA Server versions 3.0 and 4.0
U.S. Service Packs. For information on obtaining these Service Packs,
query on the following word in the Microsoft Knowledge Base (without the
spaces):
Modification Type: | Minor | Last Reviewed: | 4/28/2005 |
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Keywords: | kbbug kbfix KB180863 |
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